Bug Hunting Session
Bug 122435 - LibreOffice hangs when in Calc copying formula while in edit mode <F2> then leaving field with escape
Summary: LibreOffice hangs when in Calc copying formula while in edit mode <F2> then l...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
: 122385 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-02 21:29 UTC by Maddes
Modified: 2019-02-11 20:56 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sheets file to reproduce issue (5.92 KB, application/zip)
2019-01-02 21:30 UTC, Maddes
Details
Sheets file to reproduce issue (5.91 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-01-10 19:53 UTC, Maddes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maddes 2019-01-02 21:29:46 UTC
Description:
LibreOffice hangs when in Calc copying a formula in edit mode <F2> and then leaving the field via <ESC>


Steps to Reproduce:
1. Load attached sheet
2. COPY A1:F3 to A8
3. Change formulas in B10:E10 via <F2> and replace each $2 with $10
4. Again edit E10 via <F2>
5. Copy the whole formula via CTRL+C
6. Leave the field via <ESC>. Result: LibreOffice hangs

3.

Actual Results:
LibreOffice hangs (Calc, Write, etc.)

Expected Results:
It should plain work


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Maddes 2019-01-02 21:30:54 UTC
Created attachment 147956 [details]
Sheets file to reproduce issue
Comment 2 Maddes 2019-01-10 19:48:58 UTC
Still an issue in latest 6.2.0.2.
Comment 3 Maddes 2019-01-10 19:50:52 UTC
Recognized that in Step it should be "...and replace each $2 with $9"
Comment 4 Maddes 2019-01-10 19:53:12 UTC
Created attachment 148228 [details]
Sheets file to reproduce issue
Comment 5 raal 2019-01-10 20:32:30 UTC
No crash with Version: 6.3.0.0.alpha0+
Build ID: 892a5cfe557edb405ec0037676f02a1c24dd76ec
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 6 Maddes 2019-01-10 21:57:12 UTC
Cannot find a nightly build for Windows 6.3.0.0.alpha0+ to test it.
Comment 7 raal 2019-01-11 07:22:46 UTC
(In reply to Maddes from comment #6)
> Cannot find a nightly build for Windows 6.3.0.0.alpha0+ to test it.

You can download it here: http://dev-builds.libreoffice.org/daily/master/
and choose one of windows build, for example https://dev-builds.libreoffice.org/daily/master/Win-x86@39/current/
Comment 8 raal 2019-01-11 08:39:53 UTC
Confirm with 6.3, win. Regression.
Comment 9 Maddes 2019-01-15 16:14:09 UTC
Thanks for the hint.

Also reproducible on recent master for Win 64-Bit:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 423d70f7e45749fad680b3dfe0ccdaed1c1afb19
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_23:07:06
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 10 Xisco Faulí 2019-01-16 13:17:35 UTC
I've tried to bisect this but the result was incorrect. I let others to try it...
Comment 11 Xisco Faulí 2019-01-16 22:00:33 UTC
*** Bug 122385 has been marked as a duplicate of this bug. ***
Comment 12 Buovjaga 2019-01-17 18:04:25 UTC
Bibisected with win32-6.2 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/3d8c159841bcab7365b2bed3df71ed3c15188312%5E!/

tdf#109085: don't assume MtaOleReq window is still valid at shutdown

Notice: there was suspicion of bad result with the document in this report for me as well. Thus, I did a second bibisect with the document altix_Nummern_Test_Einfrieren_V4d2.ods attachment 147902 [details] in the duplicate bug (copy row 14 over row 11, F2 a cell, select contents, copy -> hang). It pointed to the same commit and I was able to verify by checking out the blamed commit vs. previous commit.

Adding Cc: to Mike Kaganski

This is Win-only, not reproducible on Linux.
Comment 13 Maddes 2019-02-04 15:58:19 UTC
This is still not fixed in 6.2.0-rc3 and I see it as critcial.
Comment 14 Commit Notification 2019-02-05 09:10:43 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/11a2809e369b2a6fcbb2d7f0db131a945557c6e2%5E%21

tdf#122435: reimplement fix for tdf#109085

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Stefan_Lange_KA@T-Online.de 2019-02-06 07:34:18 UTC
I have succesfully tested with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 82fb7f9f90a3ba9d53b3412124e513aa78ddca10
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-05_23:41:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

both test cases (from this bug and from duplicate Bug 122385) and also the case in my "production document" that caused me to report Bug 122385.

Many thanks for the resolution of this bug! I hope the fix will be pushed to LO 6.2.1 soon.
Comment 16 Xisco Faulí 2019-02-06 12:20:06 UTC
Issue verified in

Version: 6.3.0.0.alpha0+
Build ID: 429f6cde5dcd48077e064de6dc0378886db7f842
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Mike Kaganski, thanks for fixing this!!
Comment 17 Maddes 2019-02-06 21:33:06 UTC
I can confirm fixed in current daily builds.
Please port this fix also into 6.2.x branch. Thanks.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 82fb7f9f90a3ba9d53b3412124e513aa78ddca10
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-02-05_23:41:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Comment 18 Commit Notification 2019-02-08 14:46:28 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9d7baded9f315096f247af15a23fd899fc4facc3%5E%21

tdf#122435: reimplement fix for tdf#109085

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Stefan_Lange_KA@T-Online.de 2019-02-11 03:22:24 UTC
I have made all my tests as written in Comment 15 also with
Version: 6.2.1.0.0+ (x64)
Build ID: 16b8cb5e1bce0098b253395030b3c8ae9f5ae39a
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2019-02-11_00:32:44
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded
Result: All were OK, LO didn't hang in any case.
Many thanks! I hope the fix will be pushed still in LO 6.2.1 rc1 planned for these days.
Comment 20 Maddes 2019-02-11 20:56:25 UTC
Checked that the fix works on 6.2.1. Thanks for making 6.2 useable again.

Version: 6.2.1.0.0+ (x64)
Build ID: 16b8cb5e1bce0098b253395030b3c8ae9f5ae39a
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-2, Time: 2019-02-11_00:32:44
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded