Bug Hunting Session
Bug 122449 - Crash in: mergedlo.dll when closing "Edit Index Entry" dialog (gen/gtk)
Summary: Crash in: mergedlo.dll when closing "Edit Index Entry" dialog (gen/gtk)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.1 rc
Hardware: All All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
: 123007 (view as bug list)
Depends on:
Blocks: TableofContents-Indexes-Dialog
  Show dependency treegraph
 
Reported: 2019-01-03 18:41 UTC by Dave Barton
Modified: 2019-02-08 12:46 UTC (History)
8 users (show)

See Also:
Crash report or crash signature: ["vcl::Window::ImplGetWindowExtentsRelative(vcl::Window *,bool)"]


Attachments
bt with debug symbols (6.62 KB, text/plain)
2019-01-04 09:02 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Barton 2019-01-03 18:41:16 UTC
This bug was filed from the crash reporting server and is br-bf19d5e4-8c61-4a3d-9921-a293a3f236aa.
=========================================
Also crash report: 28a1095c-7a88-4e5d-85ed-5cfb48039a76

Version: 6.2.0.1 (x64)
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 8; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: en-IE (en_GB); UI-Language: en-US

Attempting to view an alphabetical index crashes LO. Document recovery succeeds on restart.
Test document: https://documentation.libreoffice.org/assets/Uploads/Documentation/en/CG4.1/ODT/CG4102-EnterEditFormatData.odt
On page 8 there is an alphabetical index marker before the words "Autocorrection options". Right click on the marker and select the "Index Entry..." option to open the "Edit Index Entry" dialog, then click the "Close" button. Click anywhere in the document to crash the program.

Subsequent tests following the above steps on other alphabetical indexes in this or other documents generate identical crashes.

Additional note: On restart the LO splash screen flashes in an endless loop and can only be stopped by killing the process.
Comment 1 Dave Barton 2019-01-03 18:55:30 UTC
Further tests on a Windows 10 machine produce identical crashes. Appears to be 100% reproducible on Windows.

Will test on a couple of Linux boxes and and a macOS machine in the the next 24 hours.
Comment 2 Telesto 2019-01-03 18:57:19 UTC
Repro
Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-06_23:55:16
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL

but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 3 Dave Barton 2019-01-03 19:39:30 UTC
Installed and retested with
Version: 6.1.4.2 (x64)
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Windows 6.1; UI render: default; 
Locale: en-IE (en_GB); Calc: group threaded

Failed to reproduce the crash condition.
Comment 4 Julien Nabet 2019-01-04 09:02:48 UTC
Created attachment 147991 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated yesterday, I could reproduce this with gen rendering not with gtk3 one.
Comment 5 raal 2019-01-04 16:34:12 UTC
This seems to have begun at the below commit.
Adding Cc: to XXX ; Could you possibly take a look at this one?
Thanks

3aab96b35d868d30192be278ac4f39e68b2b7f85 is the first bad commit
commit 3aab96b35d868d30192be278ac4f39e68b2b7f85
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Mon Nov 5 15:21:20 2018 +0100

    source sha:e3c6c89588fc6b85663444d701f782e73bb572c1
author	Caolán McNamara <caolanm@redhat.com>	2018-11-02 09:50:31 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-05 13:21:29 +0100
commit	e3c6c89588fc6b85663444d701f782e73bb572c1 (patch)
tree	47ecffe8be56efa3e150841d7de791308ef8ee03
parent	13b4c191cb251e9218bb9c99140cff7c52fd04db (diff)
weld SwIndexMarkModalDlg cluster
Comment 6 raal 2019-01-04 16:34:54 UTC
Adding Cc: to Caolán McNamara
Comment 7 Commit Notification 2019-01-09 21:08:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b01008eb17a1d37c3d020b86a5ba6fecd59b27ea%5E%21

Resolves: tdf#122449 crash after dismissing edit index entry dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2019-01-09 21:09:34 UTC
backport to 6-2 in gerrit, fixed in master
Comment 9 Xisco Faulí 2019-01-09 23:30:14 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 4f846cbc5ab3089648d36f2ba03b980cf7e31c0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, Thanks for fixing this !!

Cherry-picked to 6-2-0 -> https://gerrit.libreoffice.org/#/c/66057/
Comment 10 Commit Notification 2019-01-09 23:30:36 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d5c09698b02cc41cba0719d9a2e61690a427b46b%5E%21

Resolves: tdf#122449 crash after dismissing edit index entry dialog

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-01-11 21:10:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/52af98a739daccbd29f9c6626e81203454de742a%5E%21

Resolves: tdf#122449 crash after dismissing edit index entry dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Dave Barton 2019-01-12 19:50:08 UTC
Still present in 6.2.0.2 Bugzilla refused additional crash report.
Hopefully, fix will appear in 6.2.0.3
Comment 13 Xisco Faulí 2019-01-13 17:46:27 UTC
(In reply to Dave Barton from comment #12)
> Still present in 6.2.0.2 Bugzilla refused additional crash report.
> Hopefully, fix will appear in 6.2.0.3

Yes, see comment 11
Comment 14 Xisco Faulí 2019-01-28 09:58:02 UTC
*** Bug 123007 has been marked as a duplicate of this bug. ***
Comment 15 Commit Notification 2019-01-30 14:10:32 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d165ab3d716c87d3d274f58adc0c37aaedf61e7c%5E%21

uitest for tdf#122449

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Jörn Schwarz 2019-02-08 12:25:54 UTC
Version 6.2.0.3, Windows 10: the bug is not present anymore