Download it now!
Bug 122624 - FILEOPEN/FILESAVE DOCX LibreOffice Writer always shows the first row of the OLE embedded XLSX spreadsheet
Summary: FILEOPEN/FILESAVE DOCX LibreOffice Writer always shows the first row of the O...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2019-01-10 08:25 UTC by NISZ LibreOffice Team
Modified: 2019-03-14 20:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot showcasing the issue. (153.88 KB, image/png)
2019-01-10 08:25 UTC, NISZ LibreOffice Team
Details
The original document. (32.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-10 08:26 UTC, NISZ LibreOffice Team
Details
comparison MSO 2010 and LibreOffice 6.3 Master (145.60 KB, image/png)
2019-03-13 17:12 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-10 08:25:04 UTC
Description:
LibreOffice Writer always shows the OLE embedded XLSX spreadsheet from the first row in Microsoft Word saved DOCX documents, regardless of how it was originally positioned.

Steps to Reproduce:
    1. Create a new spreadsheet in Microsoft Excel with multiple rows of content and save the file as XLSX.
    2. Create a new document in Microsoft Word and insert the newly created XLSX file as OLE object.
    3. Click twice on the embedded XLSX, resize the object borders and scroll down until the first few rows aren't visible.
    4. Click out from the XLSX to see the result. Make sure that the first few rows of the OLE embedded XLSX aren't visible.
    5. Save the file as DOCX.
    6. Open the file both in LibreOffice Writer and Microsoft Word and compare them.

Actual Results:
LibreOffice writer will show the first worksheet of the embedded XLSX file, while Microsoft Word will show the one that was originally selected.

Expected Results:
Both LibreOffice Writer and Microsoft Word should show the same worksheet of the OLE embedded XLSX file.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-10 08:25:39 UTC
Created attachment 148198 [details]
A screenshot showcasing the issue.
Comment 2 NISZ LibreOffice Team 2019-01-10 08:26:11 UTC
Created attachment 148199 [details]
The original document.
Comment 3 Xisco Faulí 2019-01-10 12:27:54 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=505ce3a2ba3adeef46daecbf9b14c42cea211408 which is the same as in bug 122594

*** This bug has been marked as a duplicate of bug 122594 ***
Comment 4 László Németh 2019-02-07 19:07:04 UTC
(it will be solved differently, than the related bug of selected sheets)
Comment 5 Xisco Faulí 2019-02-11 16:06:16 UTC
(In reply to László Németh from comment #4)
> (it will be solved differently, than the related bug of selected sheets)

Yep, you're right. Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 8c0bb7692a5ae3f1c0d1966903baef013b50a7e6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Commit Notification 2019-02-18 22:58:58 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6fb9ef15aa67b91dec016873ad8224db2323291c%5E%21

tdf#122624 XLSX OLE in DOCX: import view positions

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-02-19 00:14:59 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/3707e2a7b8b05617b0afb75374f866c967593861%5E%21

tdf#122624 XLSX OLE in DOCX: export view positions

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2019-03-13 17:12:39 UTC
Created attachment 149945 [details]
comparison MSO 2010 and LibreOffice 6.3 Master

it looks almost perfect now. However, the left/right edges are hidden. See comparison
Comment 9 Xisco Faulí 2019-03-13 17:16:46 UTC
(In reply to Xisco Faulí from comment #8)
> Created attachment 149945 [details]
> comparison MSO 2010 and LibreOffice 6.3 Master
> 
> it looks almost perfect now. However, the left/right edges are hidden. See
> comparison

Actually this problem is not related to https://git.libreoffice.org/core/+/6fb9ef15aa67b91dec016873ad8224db2323291c%5E%21 so settting it as VERIFIED.
I'll create a follow-up bug
Comment 10 Xisco Faulí 2019-03-13 17:18:30 UTC
@László Németh, considering it's a regression, should we backport it to 6-2 branch or you prefer to keep it just in master ?
Comment 11 László Németh 2019-03-14 20:04:58 UTC
(In reply to Xisco Faulí from comment #10)
> @László Németh, considering it's a regression, should we backport it to 6-2
> branch or you prefer to keep it just in master ?

@Xisco: it would be better to backport, but I forgot to do it. Unfortunately, I have got some technical problems now and tomorrow, but I will start the backport next week, if it's ok. Thanks for your review and feedback! László