Bug Hunting Session
Bug 122698 - Problematic behavior when inputting Chinese in a text block
Summary: Problematic behavior when inputting Chinese in a text block
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE RTL-Textbox
  Show dependency treegraph
 
Reported: 2019-01-14 06:43 UTC by Franklin Weng
Modified: 2019-06-13 12:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screencast - strange behavior of text block input (3.84 MB, video/webm)
2019-01-14 06:56 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2019-01-14 06:43:40 UTC
Description:
In Writer 6.2 rc2, it is okay to input under normal mode.  However when inputting in a text block, the behavior is strange:

* Inputting English was okay.
* When inputting Chinese (via input method), the first Chinese character would be "eaten" and was not shown.  The second Chinese character could be shown.
* After pressing Enter to next (several) lines, when I input another Chinese character the cursor would jump back to the position of last Chinese character.
* If I input English characters at the previous step then there was nothing weird.  But when I use Ctrl-Space again to switch my input method to Chinese input mode, the cursor jumped back again.

In Impress and Draw the behavior of inputting in a text block was the similar, except the first Chinese character wouldn't be eaten.

Steps to Reproduce:
1. Open Writer 6.2 rc2 and insert a text block.
2. Input a Chinese character via input method (my IM engine is gcin)
3. The first Chinese character would be eaten, but the characters afterwards can be shown
4. Press Enter (one or several times)
5. Input another Chinese character again
6. The cursor would jump back to the position of last Chinese character and new character would be shown in the same line

Actual Results:
* In Writer the first Chinese character input in a text block would be gone, and others would be shown.
* Pressing Enter to change line was useless since when inputting another Chinese character the cursor would jump back.
* In Impress and Draw the first Chinese character would be shown correctly, but changing lines was still useless.

Expected Results:
It should act normally


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Only happened in VCL kde5 backend.
kde4 and gtk3 would not happen.
Comment 1 Franklin Weng 2019-01-14 06:56:11 UTC
Created attachment 148298 [details]
Screencast - strange behavior of text block input
Comment 2 Franklin Weng 2019-02-06 09:19:11 UTC
Still reproducible in

版本:6.2.0.3
組建 ID:98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU 執行緒:4; OS:Linux 4.15; UI 算繪:預設; VCL: kde5; 
語言地區:zh-TW (zh_TW.UTF-8); UI語言:zh-TW
Calc: threaded


Now in the text block the first character would not vanish, but when inputting in the next lines the cursor would still jump back to the end of the first line.
Comment 3 Xisco Faulí 2019-03-21 14:33:03 UTC
Hi Franklin,
Could you please check with LibreOffice 6.2.2.2?
OTOH, what happens if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3 ? is the issue reproduced in gtk3 ?
Comment 4 Franklin Weng 2019-03-22 00:26:10 UTC
(In reply to Xisco Faulí from comment #3)
> Hi Franklin,
> Could you please check with LibreOffice 6.2.2.2?
> OTOH, what happens if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3 ?
> is the issue reproduced in gtk3 ?

版本:6.2.2.2
組建 ID:2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU 執行緒:4; OS:Linux 4.15; UI 算繪:預設; VCL: kde5; 
語言地區:zh-TW (zh_TW.UTF-8); UI語言:zh-TW
Calc: threaded

1. This problem can still reproduced in 6.2.2.2 (version info above).
2. This problem would not be reproduced in gtk3 at all (since the alpha/beta version).
Comment 5 Jan-Marek Glogowski 2019-05-24 17:00:06 UTC
There were many fixes to the qt5 IM support. Can you test current master build from here https://dev-builds.libreoffice.org/daily/ ?
Comment 6 Franklin Weng 2019-06-13 12:15:06 UTC
(In reply to Jan-Marek Glogowski from comment #5)
> There were many fixes to the qt5 IM support. Can you test current master
> build from here https://dev-builds.libreoffice.org/daily/ ?

It works in

版本:6.3.0.0.alpha1+
組建 ID:77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU 執行緒:4; OS:Linux 4.19; UI 算繪:預設; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
語言地區:zh-TW (zh_TW.UTF-8); UI語言:zh-TW
Calc: threaded

Thanks!