Bug 122722 - Hiding characters will crash. Crash in: SwAttrIter::CtorInitAttrIter(SwTextNode &,SwScriptInfo &,SwTextFrame const *)
Summary: Hiding characters will crash. Crash in: SwAttrIter::CtorInitAttrIter(SwTextN...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: highest critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-01-15 09:49 UTC by baffclan
Modified: 2019-01-30 22:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SwAttrIter::CtorInitAttrIter(SwTextNode &,SwScriptInfo &,SwTextFrame const *)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2019-01-15 09:49:48 UTC
This bug was filed from the crash reporting server and is 
br-1c761de8-b3a1-4e2d-ba85-0cf4c2f8f0ab,
br-2b94f8b6-fa33-4559-9d6c-82bcb1978cd2,
br-0d839a8b-c74f-4347-94c0-4e76ca445bdd.
=========================================

Hiding characters will crash.


STR:
1. Start LibreOffice
2. Create New Writer Document
3. Type "LibreOffice" in Writer
4. Select "LibreOffice" with mouse, and right click
5. Appear Context Menu, Character -> Character
6. Opened Character, Select "Font Effect" tab
7. Check Hidden, and click [OK]
8. Crash a LibreOffice


Version: 6.2.0.2 (x64)
Build ID: 2ce5217b30a543f7666022df50f0562f82be0cff
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 1ca409292272632f443733450313de5a82c54a9c
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2018-11-20_20:11:12
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-01-15 09:58:48 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9bda4a67565817f0a26f48c4a4b9723894a385f5

author	Michael Stahl <Michael.Stahl@cib.de>	2018-09-14 14:35:00 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:33 +0200
commit	9bda4a67565817f0a26f48c4a4b9723894a385f5 (patch)
tree	316bc5f268763580998321bfdef2510393698a63
parent	6410a654058c3dc30461aa25d0197e579147edcc (diff)
sw_redlinehide_2: adapt SwEditShell::GetCurWord()

Bisected with: bibisect-linux64-6.2

Adding Cc: to Michael Stahl
Comment 2 Commit Notification 2019-01-15 16:08:04 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/0623861685dd1c9daa72a1002f5b018d5c5ef03c%5E%21

tdf#122722 sw: fix hidden text crash in SwTextFrame::GetCurWord()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2019-01-15 16:08:48 UTC
fixed on master
Comment 4 baffclan 2019-01-16 11:34:11 UTC
Cannot reproduce with LibO-master/Win-x86_64@42.

Version: 6.3.0.0.alpha0+ (x64)
Build ID: eca59b6b8a0cf826ac59f77aec9acf045340c23f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-16_03:48:12
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: threaded

however, a caret is not displayed.
Therefore can not enter characters.
Comment 5 Michael Stahl (CIB) 2019-01-16 11:36:57 UTC
> however, a caret is not displayed.

i noticed that too, it's because all of the document content is "hidden".

but it turns out an older version i checked behaves the same, so it's not a regression and unrelated to this bug.

> Therefore can not enter characters.

you can actually enter characters, you just can't see them until you change the formatting (or toggle the option to view hidden content, i forget where it was in the menus...).
Comment 6 baffclan 2019-01-16 11:53:49 UTC
(In reply to Michael Stahl (CIB) from comment #5)
Thanks for information.
Does that mean that a caret is included when selecting a character?
I file bug 122754.
Comment 7 Xisco Faulí 2019-01-16 13:23:07 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 1bf68dbf53f4b5308e295058226abd6d6fb49c3d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Commit Notification 2019-01-16 13:52:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d3031765b429beed0ddae2b53b54e7633432bc23%5E%21

tdf#122722 sw: fix hidden text crash in SwTextFrame::GetCurWord()

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-01-16 13:53:29 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-0":

https://git.libreoffice.org/core/+/ba44615ff9492ac2af06fa97c301b3cd4270a9dd%5E%21

tdf#122722 sw: fix hidden text crash in SwTextFrame::GetCurWord()

It will be available in 6.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 baffclan 2019-01-19 11:57:32 UTC
(In reply to Commit Notification from comment #9)
> Michael Stahl committed a patch related to this issue.
> It has been pushed to "libreoffice-6-2-0":


br-cc1f7173-b465-4dbe-8ecf-d73aac3c0c9b
crash in swlo.dll 

Version: 6.2.0.0.beta1+ (x64)
Build ID: 2f793336df474740ca5fb0703ae1f7d5febdbff4
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-6-2, Time: 2019-01-17_21:57:05
Locale: ja-JP (ja_JP); UI-Language: en-US
Calc: CL
Comment 11 Commit Notification 2019-01-30 22:26:27 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/92cea90ee51ef27ff349d854a07bcb7d270f3c4b%5E%21

uitest for bug tdf#122722

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.