Bug 122734 - calc and draw sheet tab hardcoded black color actions
Summary: calc and draw sheet tab hardcoded black color actions
Status: RESOLVED DUPLICATE of bug 124572
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-15 15:24 UTC by andreas_k
Modified: 2019-04-08 20:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
calc screenshot (30.61 KB, image/png)
2019-01-15 15:24 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2019-01-15 15:24:48 UTC
Created attachment 148336 [details]
calc screenshot

In calc and draw you have sheets and layers. On the left you see first, previous, next, last, add and the different tabs. selected tabs are white and the tab name is bold.

compare to the font color the buttons use black #000000 I would suggest to use the font color or at least some dark gray. also the bold font look like black. As we already have white background I recommend to don't make the active tab bold. 

thanks
Comment 1 Regina Henschel 2019-01-15 17:47:09 UTC
Why is the current appearance bad?
Comment 2 andreas_k 2019-01-15 20:05:34 UTC
LibreOffice Online use the icons from the icon theme and also don't use bold for the active tab.

https://www.libreoffice.org/assets/Uploads/LibreOffice-Online-Calc.png

That's the behavior I suggest. Maybe an icon can be used, but I don't know the name.
Comment 3 Adolfo Jayme 2019-01-16 00:33:38 UTC
Yeah, it would be good for these buttons to use (new) icons from the icon themes instead of being drawn by code.
Comment 4 Heiko Tietze 2019-04-08 08:48:13 UTC
The font should comply with the system theme. And a +1 for themed icons.
Comment 5 andreas_k 2019-04-08 19:49:02 UTC
I cant wait for the patch any progress?
Comment 6 andreas_k 2019-04-08 20:45:21 UTC

*** This bug has been marked as a duplicate of bug 124572 ***