Bug 122765 - Legend interferes with pie chart after pptx import
Summary: Legend interferes with pie chart after pptx import
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.2 rc
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2019-01-16 17:20 UTC by Tamas Bunth
Modified: 2019-05-22 12:44 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
PowerPoint presentation containing a pie chart with legend (46.51 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-01-16 17:21 UTC, Tamas Bunth
Details
Screenshot how it looks like with PowerPoint (40.20 KB, image/png)
2019-01-16 17:23 UTC, Tamas Bunth
Details
This is how it looks when opened with LibreOffice (master) (89.84 KB, image/png)
2019-01-16 17:24 UTC, Tamas Bunth
Details
This is how it looks after reverting commit 0fc41c53dfbd21e526fb0ad68a6651693c4a2ecd (89.38 KB, image/png)
2019-01-16 17:25 UTC, Tamas Bunth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamas Bunth 2019-01-16 17:20:02 UTC
Description:
I attached 3 screenshots of the same pptx file below. The first attachment shows how it looks when opened with PowerPoint. The second screenshot shows how it looks like with current master.

The third screenshot is made right before commit 0fc41c53dfbd21e526fb0ad68a6651693c4a2ecd.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=0fc41c53dfbd21e526fb0ad68a6651693c4a2ecd

As you can see, there are some differences between the appearances. Which I'm interested in is the distance of the legend and the pie chart itself. They should not interfere.

Steps to Reproduce:
1. Open attached Powerpoint (pptx) presentation with LibreOffice

Actual Results:
Legend interferes with pie chart

Expected Results:
Legend should not interfere with pie chart. There should be some space between them.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Tamas Bunth 2019-01-16 17:21:32 UTC
Created attachment 148367 [details]
PowerPoint presentation containing a pie chart with legend

PowerPoint reproducer attached
Comment 2 Tamas Bunth 2019-01-16 17:23:36 UTC
Created attachment 148368 [details]
Screenshot how it looks like with PowerPoint

There can be seen more differences. What I'm interested in is the distance between the legend and the pie chart.
Comment 3 Tamas Bunth 2019-01-16 17:24:49 UTC
Created attachment 148369 [details]
This is how it looks when opened with LibreOffice (master)
Comment 4 Tamas Bunth 2019-01-16 17:25:56 UTC
Created attachment 148370 [details]
This is how it looks after reverting commit 	0fc41c53dfbd21e526fb0ad68a6651693c4a2ecd
Comment 5 Durgapriyanka 2019-01-16 18:20:18 UTC
Thank you for reporting the bug.I confirm this bug in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 6 Xisco Faulí 2019-05-16 09:55:08 UTC
Dear Bartosz,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 7 Xisco Faulí 2019-05-21 10:57:33 UTC
I guess this should be tagged as a regression
Comment 8 Commit Notification 2019-05-21 19:35:56 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/10609749126ca76eaf12904d4cce9cc5a16d8405%5E%21

tdf#122765: Legend interferes with pie chart after pptx import

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-05-22 12:44:07 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: e7fb44b8c86b4dce1d4c6f15752cc3bf62b14888
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamás Zolnai, thanks for fixing this issue!!