Bug 122776 - Improve: Moving slides require to wait for animation finish
Summary: Improve: Moving slides require to wait for animation finish
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Slide-Page-Pane Slide-Sorter
  Show dependency treegraph
 
Reported: 2019-01-17 06:47 UTC by DarkTrick
Modified: 2019-05-02 10:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DarkTrick 2019-01-17 06:47:16 UTC
Current behaviour:
  1. Create several slides in a presentation
  2. Move(drag) one slide in between two other slides
  3 The surrounding slide will move up/down to make space for the new (still dragged) slide
  4. If the mouse button is released too fast (probably before the animation finished), the action is reverted.

Suggested behaviour:
  @4. Slide will be moved, even, if the animation is not yet finished
Comment 1 Xisco Faulí 2019-05-02 10:54:36 UTC
if it's reverted it's because it doesn't know the new slide position.
Closing as RESOLVED NOTABUG