Bug Hunting Session
Bug 122791 - Display column widths under table properties for more than just six columns
Summary: Display column widths under table properties for more than just six columns
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
Depends on:
Blocks: Writer-Table-Properties-Dialog
  Show dependency treegraph
 
Reported: 2019-01-17 16:44 UTC by Daniel Grigoras
Modified: 2019-09-13 09:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Column widths display issue (9.52 KB, image/png)
2019-01-17 16:45 UTC, Daniel Grigoras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2019-01-17 16:44:47 UTC
Description:
There is plenty of space to display the width of more than just the six column widths currently displayed. I often work with tables with more than just six columns, like the one with 28 columns I currently work and it's very cumbersome to use the arrows to navigate from one columns width to another.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Daniel Grigoras 2019-01-17 16:45:29 UTC
Created attachment 148404 [details]
Column widths display issue
Comment 2 Dieter Praas 2019-01-17 19:14:15 UTC
Daniel, just to be sure: Do you propose to add further columns in a second (third) line or do you want to extent the width of the properties dialog?
Comment 3 Roman Kuznetsov 2019-01-20 19:38:05 UTC
UX-team, what do you think?

For me it's WONTFIX.
Comment 4 Heiko Tietze 2019-01-21 11:20:09 UTC
There is space for two more, I'd say.
Comment 5 Cor Nouws 2019-01-22 20:24:35 UTC
(In reply to Heiko Tietze from comment #4)
> There is space for two more, I'd say.

I have just 4 visible. It is depending on the theme.
And there is the arrow top-right..

One might want to have 
 - a slider = faster..
 - a dialog of which the width can be adjusted by the user
Comment 6 csongor 2019-01-23 05:21:35 UTC
It would be nice if the user could resize the dialog. The number of columns could depend on the width of the dialog. 

Apart from this, a horizontal scrollbar would be nice to have, rather thank clicking the current tiny arrow symbols.
Comment 7 Heiko Tietze 2019-01-24 09:26:06 UTC
To summarize, the preferred solution is an option how many fields are shown by default and a slider to deal with the overflow. However, the quick and dirty improvement for now is to extend the dialog to 8 fields.

Adding two fields is likely an easyhack.
Comment 8 Heiko Tietze 2019-02-20 13:30:23 UTC
Two code pointers sw/source/ui/table/tabledlg.cxx and sw/uiconfig/swriter/ui/tablecolumnpage.ui. Just adding two spin buttons is a quick and dirty solution. 

It would be really cool when we get a table/grid instead that works in a WYSIWYG manner.
Comment 9 Heiko Tietze 2019-09-05 11:54:51 UTC
https://gerrit.libreoffice.org/#/c/78648/ 

Still some minor issues with the patch. And ultimately it won't show 8 spin buttons on the tab because gtk3 uses large controls. It works well with gtk2 and perhaps also Qt5.
Comment 10 Commit Notification 2019-09-13 07:21:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e1ec771c60d1fe03651b24f938589863c3882bc8%5E%21

Related: tdf#122791 take *final* dialog preferred size

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Heiko Tietze 2019-09-13 09:27:23 UTC
(In reply to Heiko Tietze from comment #9)
> https://gerrit.libreoffice.org/#/c/78648/ 

With Caolan's patch, the dialog shows now correctly up to 6 spinner. While my patch would increase the value to 8, it's actually limited to the number that can be shown with the themed control size. Gtk3 has large controls and even macOS shows only 5 spinners. So we better not change the code and blame the system => WONTFIX.

I'll abandon the patch.