Bug 122830 - UI: Hint is a empty gray box for line-setting in the cell appearance dialog of the sidebar with OpenGL enabled (very flickery without)
Summary: UI: Hint is a empty gray box for line-setting in the cell appearance dialog o...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 122832 (view as bug list)
Depends on:
Blocks: RenderContext Flickering-UI
  Show dependency treegraph
 
Reported: 2019-01-20 12:56 UTC by Telesto
Modified: 2020-08-28 13:13 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-20 12:56:20 UTC
Description:
UI: Hint is a empty gray box for line-setting in the cell appearance dialog of the sidebar

Steps to Reproduce:
1. Open Calc
2. Sidebar -> Properties panel -> Cell Appearance panel
3. Enable borders for a cell
4. Click line style box & expand it
5. Hoover over the items. Very flickery without OpenGL. Gray box with openGL

Actual Results:
Gray box without text

Expected Results:
A yellow hint box


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Xisco Faulí 2019-01-21 13:01:30 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8ea1bdce62880448a42bcc4a283308bdccebb2cf

author	Mike Kaganski <mike.kaganski@collabora.com>	2018-11-22 15:20:16 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2018-11-23 08:37:34 +0100
commit	8ea1bdce62880448a42bcc4a283308bdccebb2cf (patch)
tree	e89467d05de015374553dde1b7615dd4a18fda44
parent	f23aa1a51cb1beea4ebe3a61ba0c9b3abd844fd9 (diff)
Get rid of ValueSet's internal VirtualDevice, draw to RenderContext
 
Bisected with: bibisect-linux64-6.3

Adding Cc: to Mike Kaganski

Reproduced with GTK but not with GTK3
Comment 2 Telesto 2019-01-21 13:11:25 UTC
Not limited to Calc

1. Insert a shape
2. Sidebar -> Properties deck -> Click Line width
Comment 3 Xisco Faulí 2019-01-21 13:22:58 UTC
*** Bug 122832 has been marked as a duplicate of this bug. ***
Comment 4 Miklos Vajna 2019-07-24 12:58:23 UTC
Adjusting the tracker bug list, this is not a regression from dca01def7885ad69cf66edd75cf8207a5adb64f9.
Comment 5 V Stuart Foote 2019-08-19 15:20:12 UTC
STR from dupe 122832 for Sidebar Gallery items flicker without OpenGL rendering (i.e. not double buffered).

On a Windows build
Use default GDI rendering (Tools -> Options -> View) no HA, no OpenGL
Open Writer, Calc, Draw or Impress
On Sidebar select Gallery deck, any theme (default is Arrows)
mouse pointer over several graphic thumbnails

Note lack of double buffering and the UI flicker when redrawn.

=-testing-=
Windows 10 Ent 64-bit en-US (1903) with
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 6 Buovjaga 2020-08-28 13:13:50 UTC
As Skia with Vulkan will replace OpenGL UI rendering on all platforms, it does not make sense to keep OpenGL UI reports open.

Details about Skia: https://www.collaboraoffice.com/success-story/implementing-vulkan-capable-libreoffice-user-interface-using-the-skia-library/