Bug 125989 - With default rendering, palette swatches of the Color picker flicker on mouse over
Summary: With default rendering, palette swatches of the Color picker flicker on mouse...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 126283 128546 128726 129066 132804 135145 (view as bug list)
Depends on:
Blocks: RenderContext Flickering-UI
  Show dependency treegraph
 
Reported: 2019-06-18 14:55 UTC by V Stuart Foote
Modified: 2020-07-26 14:54 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2019-06-18 14:55:20 UTC
With 'default' rendering mode. The Draw 'Color Bar' is rock solid, but the Color picker dialog across the UI flickers badly on mouse pointer movement between swatches. No issue with OpenGL rendering.

=-testing-=
On Windows 10 Home 64-bit en-US with
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 99971d009e9c96d1d47aec14ecfbfeaa06dc140d
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-18_03:59:27
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-06-18 16:25:03 UTC
confirm in

Version: 6.4.0.0.alpha0+ (x64)
Build ID: b59a691d2f6b0d1b94ec68fa01768325e4a34dc9
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-17_23:52:41
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

this color picker flickers in SideBar in Draw and in formatting toolbar in Writer too

And Color bar (now it's in View->Color Bar) in Draw fickers also for me
Comment 2 V Stuart Foote 2019-06-18 16:33:30 UTC
regards the Draw 'Color bar'

/me embarrassed, if using the scroll bar or actually clicking to change a color swatch the 'Color bar' flickers. Weird because mouse over does have an action (i.e. popping out tooltip with color) but it does not seem to refresh elements on the toolbar. A pick or using the scrollbar to reposition does, and flickers.
Comment 3 Xisco Faulí 2019-06-28 14:46:06 UTC
Also reproduced in

Version: 6.4.0.0.alpha0+
Build ID: a294457eb95e60028539b6783abac78b56561fe2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-06-28 15:14:41 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8ea1bdce62880448a42bcc4a283308bdccebb2cf

author	Mike Kaganski <mike.kaganski@collabora.com>	2018-11-22 15:20:16 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2018-11-23 08:37:34 +0100
commit	8ea1bdce62880448a42bcc4a283308bdccebb2cf (patch)
tree	e89467d05de015374553dde1b7615dd4a18fda44
parent	f23aa1a51cb1beea4ebe3a61ba0c9b3abd844fd9 (diff)
Get rid of ValueSet's internal VirtualDevice, draw to RenderContext
This improves support for Online HiDPI scenarios.

Bisected with: bibisect-linux64-6.3 

Adding Cc: to Mike Kaganski
Comment 5 Xisco Faulí 2019-07-08 10:50:45 UTC
*** Bug 126283 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2019-07-08 10:51:35 UTC
it seems other UI components are affected. Increasing severity towards 6.3 release...
Comment 7 Xisco Faulí 2019-09-28 15:35:53 UTC
@Miklos, if you have a moment, could you please take a look at this issue? I tried to fixed it like we fix other similar bugs ( bug 126321 or bug 127676 ) but it didn't work...
Comment 8 Xisco Faulí 2019-11-05 11:48:03 UTC
*** Bug 128546 has been marked as a duplicate of this bug. ***
Comment 9 V Stuart Foote 2019-11-12 02:29:16 UTC
*** Bug 128726 has been marked as a duplicate of this bug. ***
Comment 10 Xisco Faulí 2019-11-28 10:45:53 UTC
*** Bug 129066 has been marked as a duplicate of this bug. ***
Comment 11 V Stuart Foote 2020-05-07 16:43:23 UTC
*** Bug 132804 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2020-07-26 14:37:14 UTC
*** Bug 135145 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2020-07-26 14:54:52 UTC
This looks to be corrected at the 7.0.0 release. I'd not noticed working mostly with Skia rendering recently.

Still present 6.4.5, but WFM at least as of:

Version: 7.0.0.0.beta2 (x64)
Build ID: 1c213561a365b5666167321de68c9977500c9612
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

But if anyone wants to reverse bibisect, might apply to other RenderContext bug 91488 / Flickering-UI bug 112889 BZ issues.