Bug 122844 - Crash in: SwTableBox::GetSttIdx ( steps in comment 7 ) (gtk/gtk3)
Summary: Crash in: SwTableBox::GetSttIdx ( steps in comment 7 ) (gtk/gtk3)
Status: RESOLVED DUPLICATE of bug 135098
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Crash-Assert gtk3-whipping-boy Crash
  Show dependency treegraph
 
Reported: 2019-01-21 07:35 UTC by Paolo Redaelli
Modified: 2020-08-06 08:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["SwTableBox::GetSttIdx"]
Regression By:


Attachments
Document to Crash LibreOffice (17.76 KB, application/vnd.oasis.opendocument.text)
2019-08-08 05:45 UTC, Kieran Grant
Details
Backtrace (35.23 KB, text/plain)
2020-05-17 20:20 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Redaelli 2019-01-21 07:35:49 UTC
This bug was filed from the crash reporting server and is br-92f7f4fe-697a-4765-b2da-cb7e7a301bbc.
=========================================
Comment 1 Dieter 2019-01-21 08:15:13 UTC Comment hidden (obsolete)
Comment 2 QA Administrators 2019-07-21 02:47:35 UTC Comment hidden (obsolete)
Comment 3 Kieran Grant 2019-08-08 05:45:35 UTC
Created attachment 153219 [details]
Document to Crash LibreOffice

This document crashes after repeatedly merging cells in rows where the second column is empty.
Comment 4 Kieran Grant 2019-08-08 05:47:18 UTC
I have encountered this bug in 6.3.0 RC3 (https://crashreport.libreoffice.org/stats/crash_details/f9e62557-b074-4502-b09a-468d7aa7430c).

The document I attached causes LibreOffice to crash (including 6.2.4.2) by repeatedly merging the cells in rows where the second column is empty.

It happens every time. The exact number of rows I need to perform this operation on varies though.
Comment 5 Kieran Grant 2019-08-08 05:50:11 UTC
Also encountered in Daily.
Version: 6.4.0.0.alpha0+
Build ID: 9ee5ad5a0b84bfa652da34694ba4f75668f06087
CPU threads: 16; OS: Linux 5.0; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-07-30_13:21:44
Locale: en-AU (en_AU.UTF-8); UI-Language: en-US
Calc: CL
Comment 6 Kieran Grant 2019-08-08 06:30:10 UTC
Using AppImage of old versions:

Earliest Version I could reproduce crash in is 6.0.0.3.
Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 16; OS: Linux 5.0; UI render: default; VCL: gtk2; 
Locale: en-AU (en_AU.UTF-8); Calc: group
(https://libreoffice.soluzioniopen.com/old/LibreOffice-6.0.0-x86_64.AppImage)

But the available version just before it does not crash:
Version: 5.4.7.2
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 16; OS: Linux 5.0; UI render: default; VCL: gtk2; 
Locale: en-AU (en_AU.UTF-8); Calc: CL
(https://libreoffice.soluzioniopen.com/old/LibreOffice-5.4.7-x86_64.AppImage)
Comment 7 Xisco Faulí 2019-08-08 08:45:51 UTC
I can reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 6d024a69164716f7856ec936a72d01a6630d2a7c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Steps:
1. open the file
2. Go to the beginning of page 3
3. Select two first cells on page 3 ( not the header )
4. merge them

-> Crash
Comment 8 Xisco Faulí 2019-08-08 08:46:48 UTC
According to https://crashreport.libreoffice.org/stats/signature/SwTableBox::GetSttIdx, seems to happen on Linux only
Comment 9 Xisco Faulí 2019-08-08 08:50:16 UTC
Also reproducible in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8
Comment 10 Martin Kofahl 2019-12-05 18:45:55 UTC
happens daily in

Version: 6.3.3.2
Build-ID: 1:6.3.3-0ubuntu0.18.04.1~lo1
CPU-Threads: 32; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

from ppa:libreoffice/ppa
Comment 11 Aron Budea 2020-05-17 20:20:13 UTC
Created attachment 160950 [details]
Backtrace

Attaching backtrace taken with a fresh master build.
Comment 12 Timur 2020-05-18 07:47:33 UTC Comment hidden (obsolete)
Comment 13 Timur 2020-05-18 08:41:51 UTC
Crash happens in 5.2 with GTK3 and no crash with GEN. 
I cannot start prior LO GUI with GTK3 or GTK.
Comment 14 Caolán McNamara 2020-08-03 12:58:18 UTC
An a11y-related crash rather than a gtk-specific crash.
Comment 15 Xisco Faulí 2020-08-06 08:21:17 UTC

*** This bug has been marked as a duplicate of bug 135098 ***