Download it now!
Bug 122917 - FILEOPEN/FILESAVE XLSX Excel table is incorrectly imported/exported
Summary: FILEOPEN/FILESAVE XLSX Excel table is incorrectly imported/exported
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2019-01-24 08:44 UTC by NISZ LibreOffice Team
Modified: 2019-03-08 06:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Excel and Calc. (158.28 KB, image/png)
2019-01-24 08:47 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Excel. (217.31 KB, image/png)
2019-01-24 08:48 UTC, NISZ LibreOffice Team
Details
Example file from Excel with an Excel table. (16.57 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-01-24 08:48 UTC, NISZ LibreOffice Team
Details
The original file saved by Calc. (14.92 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-01-24 08:49 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-24 08:44:29 UTC
Description:
Excel table is incorrect when the document is opened in Calc. Exported spreadsheet with Excel table is incorrectly opened in Excel.

Steps to Reproduce:
    1. Create a new spreadsheet in Microsoft Excel 2016.
    2. Create an Excel table. (Insert→Table)
    3. On the Table Tools > Design tab, in the Table Style Options group, select: Header Row, Total Row, Banded Rows, First Column, Last Column, Banded Columns.
    4. Deselect: Filter Button.
    5. Save the file as XLSX.
    6. Open the same file in LibreOffice Calc.

Actual results:
Banded Rows, First Column, Last Column and Banded Columns settings disappear. Filter controls are added to the table headers.

Expected results:
Excel table should have the same style as the original file opened in Microsoft Word 2016.

    7. Save the file as XLSX.
    8. Open the same file in Microsoft Excel 2016.


Actual Results:
Error message: Excel found unreadable content in filename...
Excel was able to open the file by repairing or removing the unreadable content.

Selected options: Header Row, Banded Rows, Filter Button.
Deselected options: Total Row, First Column, Last Column, Banded Columns.

Expected Results:
Spreadsheet should open correctly in Excel. Excel table should have the same style as the original file opened in Microsoft Word 2016.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-24 08:47:17 UTC
Created attachment 148581 [details]
Screenshot of the original document side by side in Excel and Calc.
Comment 2 NISZ LibreOffice Team 2019-01-24 08:48:05 UTC
Created attachment 148582 [details]
Screenshot of the original and exported document side by side in Excel.
Comment 3 NISZ LibreOffice Team 2019-01-24 08:48:36 UTC
Created attachment 148583 [details]
Example file from Excel with an Excel table.
Comment 4 NISZ LibreOffice Team 2019-01-24 08:49:03 UTC
Created attachment 148584 [details]
The original file saved by Calc.
Comment 5 Roman Kuznetsov 2019-01-27 15:06:01 UTC
Excel functional "Format as table"  is missed in LibreOffice.

*** This bug has been marked as a duplicate of bug 112371 ***
Comment 6 Aron Budea 2019-03-08 06:04:31 UTC

*** This bug has been marked as a duplicate of bug 66377 ***