Download it now!
Bug 122934 - ENDNOTE enhancement -- we should be able to COPY endnotes / footnotes and PASTE into a new document
Summary: ENDNOTE enhancement -- we should be able to COPY endnotes / footnotes and PAS...
Status: RESOLVED DUPLICATE of bug 99096
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2019-01-24 15:03 UTC by peter josvai
Modified: 2019-03-27 21:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2019-01-24 15:03:15 UTC
Description:
It would be GREAT if we could get hands on the endnotes :) 
that is, if we could copy them and paste them into a new document (or a WYSIWYG html editor)... and thus create an "independent" html5 or ODT document of it...

endnotes are the same thing as TOC, only downward in structural hierarchy...
you need them likewise... and you, likewise, want to be able to "edit" them... 
(to format them, insert separators for chapters)


Steps to Reproduce:
1. create a document with endnotes
2. try to copy the end notes
3.

Actual Results:
you can only copy the entire document which will include the endnotes...
this is logical since endnotes are actually within the text...
(yet it would be GREAT to get them independently)

BUT the endnotes will lose formatting (Arab numbers)...

Expected Results:
it would be great if we could right click and choose "export endnotes"...
or "copy endnotes to clipboard as HTML(5)"

it would be also great if endnotes kept the original formatting (Arab numbers as opposed to Roman, if we have chosen that in the document)





Reproducible: Always


User Profile Reset: No



Additional Info:
PS:

a further step could be (later on) to have the endnotes (in the case of master documents) as a separate file... 
which would be automatically generated...
but the user could define an alternative end-note file...

and "tick" to overwrite this by the automatically exported endnote document
Comment 1 Timur 2019-01-24 16:42:20 UTC
I confirm that we cannot copy endnotes. Looks like inherited from OO.
Comment 2 Cor Nouws 2019-03-27 21:21:23 UTC

*** This bug has been marked as a duplicate of bug 99096 ***