Download it now!
Bug 122957 - FILESAVE DOCX Arrows go missing after saving a doc-file as docx in LO (shapes)
Summary: FILESAVE DOCX Arrows go missing after saving a doc-file as docx in LO (shapes)
Status: RESOLVED DUPLICATE of bug 99810
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard:
Keywords: filter:docx
: 122959 122965 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-01-25 11:34 UTC by NISZ LibreOffice Team
Modified: 2020-10-09 09:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file (33.50 KB, application/msword)
2019-01-25 11:34 UTC, NISZ LibreOffice Team
Details
The saved file. (16.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-25 11:35 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (274.61 KB, image/png)
2019-01-25 11:35 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-25 11:34:20 UTC
Description:
When saving the attached original file in LO as docx the the line arrows go missing.

Steps to Reproduce:
    1. Open the attached original docx in LO.
    2. Save it as docx.
    3. Reload.
    4. Notice the changes.

Actual Results:
The line arrows are missing.

Expected Results:
They should be there even after saving.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-25 11:34:53 UTC
Created attachment 148632 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-01-25 11:35:11 UTC
Created attachment 148633 [details]
The saved file.
Comment 3 NISZ LibreOffice Team 2019-01-25 11:35:33 UTC
Created attachment 148634 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 4 Durgapriyanka 2019-01-25 16:49:01 UTC
Thank you for reporting the bug. I cannot confirm this in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Dieter 2019-01-26 11:56:19 UTC
I confirm it with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 411f3a050ac2be598019d512f8ccfe041080c28f
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-01-14_03:17:11
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

But what is the difference to bug 122959?
Comment 6 Buovjaga 2019-01-31 19:34:45 UTC
(In reply to Dieter Praas from comment #5)
> But what is the difference to bug 122959?

Dieter has a point. Bug 122965 is also about the same thing. I tested all three bugs in multiple versions and they are all inherited. I am going to close the others as dupes of this.
Comment 7 Buovjaga 2019-01-31 19:34:54 UTC
*** Bug 122965 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2019-01-31 19:35:17 UTC
*** Bug 122959 has been marked as a duplicate of this bug. ***
Comment 9 Balázs Regényi 2020-10-09 09:02:13 UTC

*** This bug has been marked as a duplicate of bug 99810 ***