Download it now!
Bug 99810 - FILESAVE DOCX: Lines lost when saved as DOCX
Summary: FILESAVE DOCX: Lines lost when saved as DOCX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, filter:docx, regression
: 104475 122957 (view as bug list)
Depends on:
Blocks: Shape-ODF-OOXML-export
  Show dependency treegraph
 
Reported: 2016-05-12 20:46 UTC by Ljiljan
Modified: 2020-11-12 11:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Working document (13.20 KB, application/vnd.oasis.opendocument.text)
2016-05-12 20:46 UTC, Ljiljan
Details
Comparison (136.59 KB, application/pdf)
2016-05-12 20:47 UTC, Ljiljan
Details
Stripped Down Line Issue (9.97 KB, application/vnd.oasis.opendocument.text)
2016-12-06 23:19 UTC, Luke
Details
Arrows compared LO 7.1+ and MSO 2016 (69.06 KB, image/png)
2020-09-03 06:20 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2016-05-12 20:46:30 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36
Build Identifier: LibreOffice 5.1.3.2

I decided to create some drawings in LibreOffice and to test it as it follows:
1. Open it in Microsoft Word 2007
2. Open it in Microsoft Word Online (their web version)
3. Re-open it with LibreOffice 

Reproducible: Always

Steps to Reproduce:
1.Download original file
2. Save it in DOC or DOCX
3. Open it with Microsoft Word or LibeOffice
Actual Results:  
DOC: text in rectangle-box is not rotate, the one line is shorter
DOCX: text in rectangle-box is rotate in MS Word 2007, but it is rotated in MS Word web version, but not as original, the lines are missing
LibreOffice (reopening DOCX): rectangle size is changed, text not shown as original, arrow lines are missing


Expected Results:  
Document should be shown correctly at least in LibreOffice, but as well as in Microsoft Word.

[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Ljiljan 2016-05-12 20:46:50 UTC
Created attachment 125018 [details]
Working document
Comment 2 Ljiljan 2016-05-12 20:47:08 UTC
Created attachment 125019 [details]
Comparison
Comment 3 Buovjaga 2016-05-15 15:49:42 UTC
Repro. Yet, separate reports should be created for all issues.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 1dbdc947fcc9d843764731e6dae7ce60082576e0
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on May 14th 2016
Comment 4 Luke 2016-12-06 23:19:50 UTC
Created attachment 129361 [details]
Stripped Down Line Issue

Ljiljan,
One report should only have a single bug in it.[1]

Let's track the issue here with the arrows disappears export to docx.

The Text Boxes look good when opened in Word, so this may be a FILEOPEN issue that affects rotated/grouped text boxes. This is should be filed as a separate report.

The MS-DOC issue appears to be a limitation of the MS-DOC spec that I'm not sure is even a valid issue. 

[1] https://wiki.documentfoundation.org/QA/BugReport
Comment 5 Luke 2016-12-06 23:26:23 UTC
This is a regression. Saving with LO 4.2 resulted is the arrows being properly exported. They could be opening in both LO 4.2 and Word 2013.
Comment 6 raal 2016-12-17 20:51:58 UTC
repro Version: 4.4.0.0.alpha0+
Comment 8 QA Administrators 2018-09-10 02:36:42 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2018-09-11 10:34:15 UTC
still repro in 6.1.1.1 on Windows 7
Comment 10 Luke 2018-09-11 16:05:08 UTC
Still repo in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 12637b0f83b3a3d9d740882e0e8e7cc0a442cde2

There is some attribute of these lines that is confusing the exporter. Normal lines export to .docx fine.
Comment 11 Aron Budea 2019-04-15 03:04:21 UTC
This, too started at the following commit, like bug 112312 and bug 122962. I assume this is rather an implementation error, than a regression, but let's keep the keywords that match the user perspective.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cfb5b20cdc230320ff9f864d1cfd81aaea221da0
author		Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-18 11:03:57 +0100
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2013-12-18 11:09:47 +0100

DocxAttributeOutput::OutputFlyFrame_Impl: enable DML export by default
Comment 12 Timur 2020-09-03 06:20:58 UTC
Created attachment 165060 [details]
Arrows compared LO 7.1+ and MSO 2016

Repro 7.1+ for DOC in LO and DOCX in LO and MSO.
Comment 13 László Németh 2020-10-09 08:31:41 UTC
*** Bug 104475 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-10-09 08:31:43 UTC
Regényi Balázs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7b2f0094f86266c64972d3e505a28b2d4e5caef6

tdf#99810 DOCX export: fix lost arrow shape

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Balázs Regényi 2020-10-09 09:02:13 UTC
*** Bug 122957 has been marked as a duplicate of this bug. ***
Comment 16 NISZ LibreOffice Team 2020-11-12 10:12:11 UTC
Verified in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: a689cf1672e89cb78fbcfa14c505850927e71f58
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!