Bug 122962 - FILESAVE DOCX Missing shape after saving in LO
Summary: FILESAVE DOCX Missing shape after saving in LO
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, filter:docx, regression
: 122963 (view as bug list)
Depends on:
Blocks: DOCX-Grouped-Shapes
  Show dependency treegraph
 
Reported: 2019-01-25 11:50 UTC by NISZ LibreOffice Team
Modified: 2021-04-28 08:36 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original file (39.23 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-25 11:51 UTC, NISZ LibreOffice Team
Details
The original file after saving (23.41 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-01-25 11:51 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (286.59 KB, image/png)
2019-01-25 11:52 UTC, NISZ LibreOffice Team
Details
Screenshot of the original and exported document side by side in Writer (143.96 KB, image/png)
2020-08-27 14:32 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-01-25 11:50:40 UTC
Description:
Shape goes missing after saving the attached file in LO as docx.

Steps to Reproduce:
    1. Open the original file LO.
    2. Save it as docx.
    3. Reopen the file.
    4. Notice the missing shape.

Actual Results:
The green rectangle goes missing after saving in LO.

Expected Results:
The green rectangle should stay the same even after saving in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-01-25 11:51:11 UTC
Created attachment 148644 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-01-25 11:51:36 UTC
Created attachment 148645 [details]
The original file after saving
Comment 3 NISZ LibreOffice Team 2019-01-25 11:52:04 UTC
Created attachment 148646 [details]
Screenshot of the original and exported document side by side in Writer
Comment 4 Durgapriyanka 2019-01-25 17:03:02 UTC
Thank you for reporting the bug.I confirm the bug present in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-02-03 15:31:37 UTC
3.5.0 does not show the shape on fileopen.

Bibisected with 43max on Linux, but there were a lot of skipped commits due to crashes. The only DOCX-related commits in the range are

commit e930d96d95edc1c1e5fd54493d289a76f31a846f
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
AuthorDate: Wed Dec 18 14:31:43 2013 +0100
Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Wed Dec 18 14:53:00 2013 +0100

    DocxAttributeOutput::EndParagraph: fix export of tables in textframes

    This is triggered by
    sw/qa/extras/ooxmlexport/data/floatingtbl_with_formula.docx when DML exp
    TextFrames is enabled in non-experimental mode.


commit cfb5b20cdc230320ff9f864d1cfd81aaea221da0
Author:     Miklos Vajna <vmiklos@collabora.co.uk>
AuthorDate: Wed Dec 18 11:03:57 2013 +0100
Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
CommitDate: Wed Dec 18 11:09:47 2013 +0100

    DocxAttributeOutput::OutputFlyFrame_Impl: enable DML export by default

    This was only available in experimental mode previously. Also note that
    export of Writer TextFrames are handled separately, there DML export is
    still off by default.
Comment 6 Buovjaga 2019-04-13 20:29:59 UTC
(In reply to Buovjaga from comment #5)
> commit cfb5b20cdc230320ff9f864d1cfd81aaea221da0
> Author:     Miklos Vajna <vmiklos@collabora.co.uk>
> AuthorDate: Wed Dec 18 11:03:57 2013 +0100
> Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
> CommitDate: Wed Dec 18 11:09:47 2013 +0100
> 
>     DocxAttributeOutput::OutputFlyFrame_Impl: enable DML export by default
> 
>     This was only available in experimental mode previously. Also note that
>     export of Writer TextFrames are handled separately, there DML export is
>     still off by default.

Did a new bibisect with win32-4.3 and this was the blamed commit.
Comment 7 Buovjaga 2019-04-15 15:25:29 UTC
*** Bug 122963 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2020-03-31 15:42:06 UTC
Still reproducible in

Version: 7.0.0.0.alpha0+
Build ID: 169a10f0e4680814145b668c6320be04038d7a89
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Adding Cc: to Miklos Vajna
Comment 9 Xisco Faulí 2020-03-31 15:48:02 UTC
actually it seems to be the same issue as bug 112312

*** This bug has been marked as a duplicate of bug 112312 ***
Comment 10 NISZ LibreOffice Team 2020-08-27 14:32:53 UTC
Created attachment 164753 [details]
Screenshot of the original and exported document side by side in Writer

Checked with 

Version: 7.1.0.0.alpha0+ (x86)
Build ID: 6640d7f405d2970ba2825a9455926cc803284d01
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

This problem is still present.
Comment 11 NISZ LibreOffice Team 2020-08-31 15:52:05 UTC
This seems in Word to have grouped shape in VML.
Comment 12 Xisco Faulí 2021-02-09 14:43:07 UTC
Dear Dániel Arató,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assign it back to yourself if you're still working on this.
Comment 13 Commit Notification 2021-04-20 07:02:38 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4cb71fefc61d9015a0142f3a4fdafc5250913f2c

tdf#122962 DOCX drawingML export: fix polygon shape in group shape

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-04-21 09:59:07 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/7b3ea547bddd08e483c49ed5b3ff822f782a0aae

tdf#122962 DOCX drawingML export: fix polygon shape in group shape

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2021-04-28 08:36:20 UTC
issue verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 41ff704cc49b7097b717882616011962ecd7198f
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing the issue. Using attachment 148644 [details], the shape is not visible after roundtrip because it's shifted down. This is another issue