Download it now!
Bug 98991 - FILESAVE DOCX: Rotation Lost of Exported Text Boxes
Summary: FILESAVE DOCX: Rotation Lost of Exported Text Boxes
Status: RESOLVED DUPLICATE of bug 82627
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx, filter:rtf
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2016-03-30 19:33 UTC by Inga
Modified: 2016-12-09 12:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
comparing different textbox rotations doc, docx and odt (223.70 KB, image/png)
2016-03-30 19:33 UTC, Inga
Details
doc file (10.50 KB, application/msword)
2016-03-31 07:56 UTC, Inga
Details
docx file (4.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-03-31 07:57 UTC, Inga
Details
odt file (9.70 KB, application/vnd.oasis.opendocument.text)
2016-03-31 07:57 UTC, Inga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Inga 2016-03-30 19:33:06 UTC
Created attachment 123966 [details]
comparing different textbox rotations doc, docx and odt

Saving rotated textbox in odt has no issues, the text stays the same direction as set

when saving the same textboxes in doc has no isses with most angles except the 90 and 270 degrees, where the text does fails to turn directions

When saving in docx the text turns back to 0 degrees bet the box is strange when you click on it
Comment 1 Joel Madero 2016-03-31 06:01:00 UTC
Please attach the actual doc and docx. Marking as NEEDINFO - once attached mark as UNCONFIRMED. Thanks
Comment 2 Inga 2016-03-31 07:56:44 UTC
Created attachment 123974 [details]
doc file
Comment 3 Inga 2016-03-31 07:57:08 UTC
Created attachment 123975 [details]
docx file
Comment 4 Inga 2016-03-31 07:57:33 UTC
Created attachment 123976 [details]
odt file
Comment 5 raal 2016-03-31 08:59:06 UTC
I can confirm with Version: 5.2.0.0.alpha0+; win7
Comment 6 Luke 2016-12-06 23:46:28 UTC
The MS-DOC spec does not allow text to be rotated with its textbox. That is a new feature in OOXML.

For the docx issue, the exported document opens perfectly in MS Word 2013. This is an import, not export issue. which makes it a dupe of Bug 82627.

*** This bug has been marked as a duplicate of bug 82627 ***