Download it now!
Bug 123011 - KDE5: on wayland the gnome UI is selected
Summary: KDE5: on wayland the gnome UI is selected
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.2.5
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-01-28 10:32 UTC by Tomáš Chvátal
Modified: 2019-05-31 06:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Chvátal 2019-01-28 10:32:54 UTC
In KDE5 session on Wayland the gnome is selected:

https://github.com/LibreOffice/core/blob/293526165fcd236ba1742de2feec6ea06376e83f/vcl/unx/generic/desktopdetect/desktopdetector.cxx#L283

This should be adopted to load up based on which session is really running.
Comment 1 Michael Weghorn 2019-01-28 19:50:38 UTC
Confirmed with

Version: 6.3.0.0.alpha0+
Build ID: cb04f8bf4f46c573edcf7be5c33d5f06d89eaff4
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

@Tomáš: Since you've already found the corresponding place in the source code: Are you planning to work on this yourself?

Otherwise, I'll probably take a look as I find time.
Comment 2 Tomáš Chvátal 2019-01-28 20:04:06 UTC
Honestly soonest I could get to this is next week to do it properly. So please shoot ahead :)
Comment 3 Michael Weghorn 2019-01-29 07:31:10 UTC
https://gerrit.libreoffice.org/#/c/67044/
Comment 4 Commit Notification 2019-01-29 08:31:33 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7eccf0b3fe771a519dbdaaf536d64b5b193a723f%5E%21

tdf#123011 Detect kde5 desktop in Plasma Wayland session

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-01-29 11:28:29 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3e4478103ee1ba912d650ab447ed246f5f1cc196%5E%21

tdf#123011 Detect kde5 desktop in Plasma Wayland session

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-05-31 06:32:53 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1124e98e935cec42c51f25f1fc713285b1044d07%5E%21

Revert "tdf#123011 Detect kde5 desktop in Plasma Wayland session"

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.