Bug 123034 - Layout change after save & reload (caused by Text wrap)
Summary: Layout change after save & reload (caused by Text wrap)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 127442 (view as bug list)
Depends on:
Blocks: Regressions-row-height
  Show dependency treegraph
 
Reported: 2019-01-29 11:06 UTC by Telesto
Modified: 2020-02-18 09:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Bibisect log (2.91 KB, text/plain)
2019-01-29 16:12 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-01-29 11:06:34 UTC
Description:
Layout change after save & reload (caused by Text wrap). Maybe related to bug 122822 

Steps to Reproduce:
1. Open attachment 148732 [details]
2. Shrink column D 50%
3. Save & File reload


Actual Results:
Expanded cells after reloaded (without hidden text)

Expected Results:
The same layout as before save... 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.0.alpha0+
Build ID: 6740443311268b7d918bf4f43134d64fb78a0109
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-15_23:37:04
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 1 Telesto 2019-01-29 16:12:11 UTC
Created attachment 148739 [details]
Bibisect log

Bisected to:

author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>	2018-04-06 20:19:10 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-06-08 00:47:06 +0200
commit	1e55a47e89a9d9d6cf9cb3993484022aaf2c097b (patch)
tree	3a3372525645775c32721e59ce8c205c8f474ffd
parent	2a7f74900fb646235b74d4c9bd4690e44edc3ed4 (diff)
tdf#62268: allow row height recalculation on document load
During document load rows with style:use-optimal-row-height="true"
should recalculate it's height.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=1e55a47e89a9d9d6cf9cb3993484022aaf2c097b
Comment 2 Xisco Faulí 2019-05-02 08:37:32 UTC
Adding Cc: to Vasily Melenchuk
Comment 3 Xisco Faulí 2019-05-06 16:14:54 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: ddea172792d13516ff7e0dd43f1f78b74ade8914
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-09-17 13:44:41 UTC
*** Bug 127442 has been marked as a duplicate of this bug. ***
Comment 5 Thorsten Behrens (CIB) 2020-02-16 13:11:25 UTC
I wonder if this is NOTABUG? We can't ultimately fix *both* bug 62268 and this one; from where I stand, unless we get 100% the same font rendering on all platforms, chances are that re-flowing a document that requests optimal heights is the better choice on balance.