Bug Hunting Session
Bug 123122 - Invoking the number format dialog the format code field is blank for a user-defined date+time format.
Summary: Invoking the number format dialog the format code field is blank for a user-d...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-02-02 09:35 UTC by mike.hall
Modified: 2019-02-12 19:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
some examples of blank format code (14.22 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-02 09:35 UTC, mike.hall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mike.hall 2019-02-02 09:35:23 UTC
Created attachment 148856 [details]
some examples of blank format code

STR:
1. With 6.2.0.3, open new calc doc and select any cell
2. Format cells and enter NN MMM DD YYYY HH:MM as format code
3. Click OK
4. Format cells -> Format code box is blank; Expected NN MMM DD YYYY HH:MM

Regression from 6.1.4.2 (Win and Linux)
Comment 1 m.a.riosv 2019-02-02 14:54:34 UTC
Repro,
after insert the format and applied it works fine but can't be edited the format is blank with Ctrl+1.

Version: 6.2.1.0.0+ (x64)
Build ID: dfa1f1f872c418e89757a3985979b79e94c12fcc
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: threaded
Comment 2 raal 2019-02-04 14:01:11 UTC
This seems to have begun at the below commit.
Adding Cc: to Eike Rathke; Could you possibly take a look at this one? Thanks

33b37a9a708eb19377407d9a44187f4d55e6b113 is the first bad commit
commit 33b37a9a708eb19377407d9a44187f4d55e6b113
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Mon Oct 8 10:36:29 2018 -0700

    source sha:e85966450b770e1169f113183ce1a9a9f4dcc507

authorEike Rathke <erack@redhat.com>2018-10-02 20:11:15 +0200 committerEike Rathke <erack@redhat.com>2018-10-03 12:08:55 +0200 commite85966450b770e1169f113183ce1a9a9f4dcc507 (patch) treec1cdba8f390a854310de04ba4109d7ef0ad6ba85 parentc330763e1bfdae5894d4a0303a7a947e5b7870e0 (diff)
Related: tdf#119613 tdf#118127 suppress duplicated builtins, rework All cat
Comment 3 Eike Rathke 2019-02-05 16:20:51 UTC
The format code is there, but not selected in the Format list, only the Category User-defined is selected.

Btw, @raal, is that output
(In reply to raal from comment #2)
> authorEike Rathke <erack@redhat.com>2018-10-02 20:11:15 +0200 committerEike
> Rathke <erack@redhat.com>2018-10-03 12:08:55 +0200
> commite85966450b770e1169f113183ce1a9a9f4dcc507 (patch)
> treec1cdba8f390a854310de04ba4109d7ef0ad6ba85
> parentc330763e1bfdae5894d4a0303a7a947e5b7870e0 (diff)

really that ugly formatted, concatenating lines and even with missing blanks between field names and value contents? Or did that happen due to copy&paste? Hard to identify and select values there..
Comment 5 Eike Rathke 2019-02-06 13:42:07 UTC
Yes I know, after all it's just spotting the right place in the output ;) thanks anyway.
Comment 6 Commit Notification 2019-02-09 01:57:56 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8e12e3300592438b06b5649deaf84574de5066ba%5E%21

Resolves: tdf#123122 category is just one bit, date+time is two bits set

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2019-02-09 01:58:28 UTC
Pending review https://gerrit.libreoffice.org/67575 for 6-2
Comment 8 Xisco Faulí 2019-02-11 11:06:40 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 8c0bb7692a5ae3f1c0d1966903baef013b50a7e6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Eike, thanks for fixing this!!

it seems like a good candidate for a UI test
Comment 9 Commit Notification 2019-02-11 11:08:41 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1e66a07e648d1203f5a599d19da1227be008f276%5E%21

Resolves: tdf#123122 category is just one bit, date+time is two bits set

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-02-12 10:05:24 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/00f76006d49b24d79e5936f981705c1d7857d4b5%5E%21

uitest for bug tdf#123122

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-02-12 19:23:01 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/17dcc5c1222842c8167b233ee6e60ce93dd49f12%5E%21

uitest one more assert in test tdf123122

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.