Download it now!
Bug 123230 - LibreOffice 6.2 crashed when I clicked Tools -> Options without a document open.
Summary: LibreOffice 6.2 crashed when I clicked Tools -> Options without a document open.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-07 16:17 UTC by PhotonQyv
Modified: 2020-03-22 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PhotonQyv 2019-02-07 16:17:22 UTC
Description:
With an existing document Tools -> Options works fine, but if there is no document or you create a new empty document the application crashes.

NB. If you type some text into the new, empty document and then go for Tools -> Options it works fine again.

Also same problem with Help --> About

Steps to Reproduce:
A:
1. Open LibreOffice 6.2
2. Click on the 'Options' entry in 'Tools' menu.

Or:

B:
1. Open LibreOffice 6.2
2. Click on 'About LibreOffice' from 'Help' menu.

Actual Results:
A: Application crashes.
B: Application crashes.

Expected Results:
A: Options dialog should open.

B: About LibreOffice dialog should open.


Reproducible: Always


User Profile Reset: No



Additional Info:
If you open a new Writer or other document and type something into it, then the Options dialog appears when you click on Tools -> Options, if you open a pre-existing document and choose Options from Tools menu then dialog also opens correctly.

Actully might be a bigger issue than just the Tools -> Options menu

Since it crashed when I tried to click on Help --> About for this bug report...

Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 2; OS: Linux 4.18; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 1 Xisco Faulí 2019-02-12 13:01:04 UTC
Thank you for reporting the bug. To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 2 PhotonQyv 2019-02-12 13:41:00 UTC
(In reply to Xisco Faulí from comment #1)
> Thank you for reporting the bug. To be certain the reported issue is not
> related to corruption in the user profile, could you please reset your
> Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
> re-test?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' if the issue is still present

Right, having just checked by moving my user profile out of the way, I can confirm that it looks like some corruption in my user profile caused the issue since with a clean profile I can now open LibreOffice About and Options dialogs without a document being open.

Apologies for the trouble (:*

But, now at least the next time something happens I know what my first step, before reporting a bug, will be (:*
Comment 3 PhotonQyv 2019-04-20 14:16:13 UTC
FYI:

Recently worked out that actually it's the KDE integration bit of LibreOffice that causes the application to crash. If you don't install libobasis-kde-integration (libreoffice.org downloaded version of debs) or libreoffice-kde5 (from Ubuntu repo) then LibreOffice 6.2.2 and later don't crash if you try to do what was mentioned in my bug report.
Comment 4 Xisco Faulí 2019-04-30 10:38:54 UTC
Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 5 Xisco Faulí 2019-04-30 10:39:50 UTC
so it happens with KDE5 even with a clean profile?
Comment 6 QA Administrators 2019-10-28 03:30:53 UTC Comment hidden (obsolete)
Comment 7 PhotonQyv 2019-10-28 16:30:02 UTC
Yes, even with a clean profile. Sorry it has taken so long to get back to you. I've got used to installing it without the KDE-related packages, just using the Gnome-related ones. It has worked perfectly since then.
Comment 8 Michael Weghorn 2019-10-29 08:41:39 UTC
To further track down the cause, it'd be great if you could test with a daily development build with debug symbols as available at [1] to see whether the issue still occurs there. And if so, to record and attach a backtrace using this build as described at [2], so we can see where the crash happens.


[1] https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/
[2] https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 9 opensuse.lietuviu.kalba 2020-01-05 20:27:00 UTC Comment hidden (obsolete)
Comment 10 opensuse.lietuviu.kalba 2020-01-05 20:27:26 UTC
I can NOT reproduce this bug in KDE with kde5 VCL in LO 6.3.4.2
Comment 11 opensuse.lietuviu.kalba 2020-01-05 20:28:21 UTC Comment hidden (obsolete)
Comment 12 Michael Weghorn 2020-01-05 20:34:08 UTC Comment hidden (obsolete)
Comment 13 Roman Kuznetsov 2020-03-22 08:37:50 UTC
no problem in

Версия: 7.0.0.0.alpha0+
ID сборки: 81d982f176751a6d5f13fcb72f425a29fd077c92
Потоков ЦП: 4; ОС: Linux 5.5; Отрисовка ИП: по умолчанию; VCL: kf5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-02-28_08:11:33
Локаль: ru-RU (ru_RU.UTF-8); Язык интерфейса: ru-RU
Calc: threaded

let's close it as WFM

PhotonQyv, if you disagree with it and still have a problem, then please make actions from Comment 8 before reopen this bug. Thanks