Bug Hunting Session
Bug 123290 - android- cannot open files with writer (Android 9)
Summary: android- cannot open files with writer (Android 9)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Android
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
: 103962 127781 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-09 13:26 UTC by raal
Modified: 2019-11-09 19:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
PrintScreen od error message (63.81 KB, image/png)
2019-02-09 13:28 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2019-02-09 13:26:16 UTC
Description:
In android master I cannot open it, doc files with writer

Steps to Reproduce:
1.open android viewer
2.open off or.doc file ( docx not tested, but probably the same error)
3.

Actual Results:
Error message

Expected Results:
Open files


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-02-09 13:28:19 UTC
Created attachment 149046 [details]
PrintScreen od error message
Comment 2 raal 2019-02-09 13:28:57 UTC
Version: 6.3.0.0.alpha0+
Build ID: cb32d7870294
Comment 3 khaymatt1 2019-03-02 02:09:51 UTC
Thank you for reporting the bug. I can not reproduce the bug in 6.1.0.0.alpha0+ Build ID:484d0ea842da.
Comment 4 raal 2019-03-02 10:01:32 UTC
Still repro Version: 6.3.0.0.alpha0+
Build ID: cb32d7870294
Odt and docx file.
Comment 5 sainaledava 2019-03-29 18:23:29 UTC
Couldn't reproduce in local with latest code. Tested with emulator, api 26 - Oreo
Comment 6 sainaledava 2019-03-29 18:24:38 UTC
Please provide the android version you are version
Comment 7 raal 2019-03-30 06:37:04 UTC
(In reply to sainaledava from comment #6)
> Please provide the android version you are version

Android 9
Comment 8 sainaledava 2019-03-30 08:57:01 UTC
(In reply to raal from comment #7)
> (In reply to sainaledava from comment #6)
> > Please provide the android version you are version
> 
> Android 9

LO viewer currently targets Api 26 - Android Oreo 8.0. That might be the issue.
Comment 9 Xisco Faulí 2019-05-02 10:11:01 UTC
Hi raal,
is the issue still reproducible in master ?
Comment 10 raal 2019-05-02 10:24:29 UTC
(In reply to Xisco Faulí from comment #9)
> Hi raal,
> is the issue still reproducible in master ?

Yes, android master doesn't works.
Comment 11 Xisco Faulí 2019-10-21 11:54:08 UTC
(In reply to raal from comment #10)
> (In reply to Xisco Faulí from comment #9)
> > Hi raal,
> > is the issue still reproducible in master ?
> 
> Yes, android master doesn't works.

it should be fixed in master now

Info from ESC meeting:
    + Android viewer
       + Issue when opening any document? (Xisco)
         + Should be fixed (Cloph)

Could you please try to reproduce it with a master build from
http://dev-builds.libreoffice.org/daily/master/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the master build
Comment 12 baffclan 2019-10-22 03:46:31 UTC
Reproduce with Newest LibreOffice Viewer.

LibreOffice Viewer / Android
Version: 6.4.0.0.alpha1+
BuildID: 3aaa2ec8c603
Android-ARM@24-Bytemark-Hosting/2019-10-21_22.04.56
Comment 13 Commit Notification 2019-11-07 14:07:29 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/eb050ae015300e850553f71b4ebbd80f40f4c3f3

tdf#123290 fix android tinderbox builds/properly package libc++_shared.so

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2019-11-07 14:17:50 UTC
Moving it to NEW
Comment 15 Xisco Faulí 2019-11-07 14:20:45 UTC
*** Bug 127781 has been marked as a duplicate of this bug. ***
Comment 16 Xisco Faulí 2019-11-07 14:21:06 UTC
*** Bug 128101 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2019-11-07 14:22:36 UTC
*** Bug 127540 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2019-11-07 14:27:47 UTC
*** Bug 103962 has been marked as a duplicate of this bug. ***
Comment 19 Xisco Faulí 2019-11-09 14:56:20 UTC
I believe we can close this one as RESOLVED FIXED
Comment 20 Terrence Enger 2019-11-09 19:00:53 UTC
I still see the problem in
master~2019-11-09_01.35.17_LibreOfficeViewer-strippedUIEditing-debug.apk,
build id a79640b30ae0, running on android 8.0.0.

On 2019-10-21, I saw the problem only in the editing version of
viewer; the view-only versions opened files successfully.  I wonder
which versions other people here are reporting?

https://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/
is now offering only editing builds.  Is this a deliberate change?