Bug 123339 - FILESAVE XLSX Horizontal text alignment in comment is incorrect
Summary: FILESAVE XLSX Horizontal text alignment in comment is incorrect
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords: filter:xlsx, implementationError
Depends on:
Blocks: Calc-Comments XLSX-Comments
  Show dependency treegraph
 
Reported: 2019-02-11 11:15 UTC by NISZ LibreOffice Team
Modified: 2019-11-14 18:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the problem in Calc. (159.04 KB, image/png)
2019-02-11 11:19 UTC, NISZ LibreOffice Team
Details
Example file from Calc.(ODS) (8.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-11 11:21 UTC, NISZ LibreOffice Team
Details
Example file from Calc.(XLSX) (13.70 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-02-11 11:21 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-11 11:15:55 UTC
Description:
The text alignment in comment is incorrect when the document is saved in XLSX format.

Steps to Reproduce:
    1. Create a new spreadsheet in LibreOffice Calc.
    2. Select a cell and choose Insert→Comment.
    3. Type text.
    4. Choose Format→Align→Centered (or Right or Justified).
    5. Deselect the cell.
    6. Choose View→Comments.
    7. Save the file as XLSX.
    8. Reload the file.

Actual Results:
The text alignment in comment is Left.

Expected Results:
The text alignment in comment should be Centered (or Right or Justified).


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.3.0.0.alpha0+
Build ID: fcc5fc76c33de566cb2d02be541dcbde29d1eb8a
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Reproducible with:
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 1 NISZ LibreOffice Team 2019-02-11 11:19:25 UTC
Created attachment 149111 [details]
Screenshot of the problem in Calc.
Comment 2 NISZ LibreOffice Team 2019-02-11 11:21:13 UTC
Created attachment 149112 [details]
Example file from Calc.(ODS)
Comment 3 NISZ LibreOffice Team 2019-02-11 11:21:37 UTC
Created attachment 149113 [details]
Example file from Calc.(XLSX)
Comment 4 Durgapriyanka 2019-02-12 15:54:15 UTC
Thank you for reporting the bug.I cannot reproduce the bug. The alignment stays even after saving in XLSX format.
Comment 5 Timur 2019-02-12 16:56:47 UTC
Reproduced 6.3+ in Windows so I'll confirm. Not clear why  Durgapriyanka couldn't reproduce.
Looks from LO 3.3 so implementation error. Works OK for XLS.
Comment 6 Timur 2019-02-18 10:59:33 UTC
Filesave to XLSX was available only from LO 3.3 which is not the same as "inherited from OO 3.3".
Comment 7 Commit Notification 2019-10-08 18:58:18 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10c85f825f1fb5989490ec731fdba036c0b8e247

tdf#123339 XLSX: fix horizontal alignment in comments

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Timur 2019-11-14 18:35:21 UTC
Looks fine both in LO and MSO.