Bug 123345 - FILEOPEN | DOCX, 3D shape loses reverts back to 2D in LO.
Summary: FILEOPEN | DOCX, 3D shape loses reverts back to 2D in LO.
Status: RESOLVED DUPLICATE of bug 70039
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Shapes PPTX-3D
  Show dependency treegraph
 
Reported: 2019-02-11 14:11 UTC by NISZ LibreOffice Team
Modified: 2021-11-25 21:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original file (23.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-11 14:12 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (322.42 KB, image/png)
2019-02-11 14:12 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-11 14:11:45 UTC
Description:
When docx with a 3D shape gets opened in LO it becomes a 2D shape.

Steps to Reproduce:
    1. Open attached file in LO and MSO.
    2. Notice the changes in LO.

Actual Results:
The shape is 2D.

Expected Results:
It should stay 3D.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-02-11 14:12:31 UTC
Created attachment 149126 [details]
The original file
Comment 2 NISZ LibreOffice Team 2019-02-11 14:12:52 UTC
Created attachment 149127 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 3 Xisco Faulí 2019-02-11 14:43:42 UTC
Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 8c0bb7692a5ae3f1c0d1966903baef013b50a7e6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded


Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.15; Render: default; 

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

In previous versions, the shape is not even displayed...
Comment 4 Regina Henschel 2021-11-25 19:46:36 UTC

*** This bug has been marked as a duplicate of bug 70039 ***