Download it now!
Bug 123622 - FILEOPEN | DOCX, Text frame in header moves when opened in LO.
Summary: FILEOPEN | DOCX, Text frame in header moves when opened in LO.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.0.0
Keywords: filter:docx
: 107222 (view as bug list)
Depends on:
Blocks: OOXML-Shapes DOCX-Frames
  Show dependency treegraph
 
Reported: 2019-02-21 11:05 UTC by NISZ LibreOffice Team
Modified: 2020-07-14 11:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The original document with the text frame. (30.97 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-21 11:05 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (315.96 KB, image/png)
2019-02-21 11:05 UTC, NISZ LibreOffice Team
Details
The example file in Word and current Writer master (305.82 KB, image/png)
2020-05-18 11:59 UTC, Tibor Nagy (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-21 11:05:10 UTC
Description:
When the attached document gets opened in LO the text frame in the header with the page number gets moved to the middle and changes its shape to rectangle.

Steps to Reproduce:
    1. Open the attached document in LO and MSO.
    2. Notice the differences in LO.

Actual Results:
The frame is in the middle and it has a rectangle shape.

Expected Results:
The frame should stay on the right side and keep its circle shape.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-02-21 11:05:33 UTC
Created attachment 149475 [details]
The original document with the text frame.
Comment 2 NISZ LibreOffice Team 2019-02-21 11:05:52 UTC
Created attachment 149476 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 3 raal 2019-02-21 21:21:48 UTC
Confirm with Version: 6.3.0.0.alpha0+
Build ID: 465939feb0e9c382e5581b53b72008979ece4807
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;  and 
Version: 4.1.0.0.alpha1+
Build ID: 863d38fbfa4fb4861e476828c46410602100919
Comment 4 Commit Notification 2020-05-18 08:52:41 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/52442a4c0192cbedafe7b77459dd2c3d1cf3614b

tdf#123622 DOCX VML import: fix relative horizontal alignment

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Tibor Nagy (NISZ) 2020-05-18 11:59:17 UTC
Created attachment 160974 [details]
The example file in Word and current Writer master
Comment 6 NISZ LibreOffice Team 2020-07-14 11:11:32 UTC
*** Bug 107222 has been marked as a duplicate of this bug. ***