Bug 123629 - FILESAVE DOCX Hyperlink placed on a picture goes missing
Summary: FILESAVE DOCX Hyperlink placed on a picture goes missing
Status: RESOLVED DUPLICATE of bug 78657
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, implementationError
Depends on:
Blocks: Hyperlink DOCX-Hyperlink
  Show dependency treegraph
 
Reported: 2019-02-21 14:50 UTC by NISZ LibreOffice Team
Modified: 2019-05-31 16:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word with simple picture. (30.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-21 14:51 UTC, NISZ LibreOffice Team
Details
Example file saved from LO. (26.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-21 14:51 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer. (243.36 KB, image/png)
2019-02-21 14:52 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-21 14:50:56 UTC
Description:
Word Hyperlink placed on a picture goes missing when the file is saved as docx in LO and reloaded.

Steps to Reproduce:
    1. Create a docx in MSO.
    2. Insert a picture with: Insert→ Picture
    3. Select the picture→ Insert→ Hyperlink→ Adress: https://libreoffice.org
    4. Save and exit the file.
    5. Open the file in LO and save it as docx.
    6. Reopen the file in LO
    7. Try to activate the Hyperlink.

Actual Results:
The Hyperlink doesn’t activate and its missing.

Expected Results:
The Hyperlink works even if it was saved in LO.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2019-02-21 14:51:26 UTC
Created attachment 149486 [details]
Example file from Word with simple picture.
Comment 2 NISZ LibreOffice Team 2019-02-21 14:51:45 UTC
Created attachment 149487 [details]
Example file saved from LO.
Comment 3 NISZ LibreOffice Team 2019-02-21 14:52:02 UTC
Created attachment 149488 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 4 Durgapriyanka 2019-02-22 19:17:07 UTC
Thank you for reporting the bug. I can confirm the bug present in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-04-06 12:30:29 UTC
In 5.0.2 and older the hyperlink does not exist on fileopen.
In 5.3.0 the hyperlink disappears on filesave.
I think we can call this an implementationError.
Tested on Win 10
Comment 6 Gabor Kelemen 2019-05-31 16:01:01 UTC

*** This bug has been marked as a duplicate of bug 78657 ***