Bug 123651 - FILEOPEN DOCX Shape move out of its original place
Summary: FILEOPEN DOCX Shape move out of its original place
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.3.0
Keywords: bibisected, bisected, filter:docx, regression
: 113742 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-02-22 13:06 UTC by NISZ LibreOffice Team
Modified: 2019-08-06 12:07 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document side by side in Word and Writer. (208.35 KB, image/png)
2019-02-22 13:07 UTC, NISZ LibreOffice Team
Details
The original file. (33.21 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-02-22 13:08 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-02-22 13:06:30 UTC
Description:
The shape move out of its original place when the attached file is opened in LibreOffice Writer 6.3.0.0.alpha0+.

Steps to Reproduce:
    1. Open the attached DOCX file in LibreOffice Writer.
    2. Open a copy in Microsoft Word.
    3. Compare the original file opened in Writer and Word.
    4. View the attached screenshot.

Actual Results:
The shape move out of its original place in LO.

Expected Results:
The arrow shape should stay in its original place.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.3.0.0.alpha0+
Build ID: 9d7620613d3ea2feb45a7ff57c4d2544bb1c6fe6
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded


Bibisected:
 909daec7c7fa8c20d9cadfdfed1236fdb5680e59 is the first bad commit
commit 909daec7c7fa8c20d9cadfdfed1236fdb5680e59
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Feb 7 05:09:53 2019 -0800

    source 961ba62df045473e5793d9e103be86eaad8d9575

    source 961ba62df045473e5793d9e103be86eaad8d9575

:040000 040000 f53e4fdcb69413440e3185eaa8f0babaaaf4a573 70a1760c277d045449c7bce44ab3a533dd025769 M      instdir


commit 961ba62df045473e5793d9e103be86eaad8d9575
author Miklos Vajna <vmiklos@collabora.com> Thu Feb 07 11:06:24 2019 +0100 
committer Miklos Vajna <vmiklos@collabora.com> Thu Feb 07 12:25:07 2019 +0100 
tree 4713751f2c803da99928bf7caedd94ee7de02ac5
parent 6673aa3fefad3b64469e3c6457161e09f6c27f5f




$ git bisect log
# bad: [3c256553a8b50c8d77377485f346590fa6bb0310] source 9d7620613d3ea2feb45a7ff57c4d2544bb1c6fe6
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'master' 'oldest'
# good: [35c7042f9064f6b7a37dd2859d0f9dc05a9fbfa5] source 1a4a78efc7c8bc06de958ce64c6be5f5ef3f1e2d
git bisect good 35c7042f9064f6b7a37dd2859d0f9dc05a9fbfa5
# good: [ec5285157b65d54c74439f237b9db3a6d1ba51be] source f3bfae052cf7feb0baca40f9b7a29033126724c1
git bisect good ec5285157b65d54c74439f237b9db3a6d1ba51be
# good: [613f7c783dd75a6fa8d1a6e52de257b4f6fa2154] source 8a1321362a0229a25869e4e3d0422a5a51c5b5be
git bisect good 613f7c783dd75a6fa8d1a6e52de257b4f6fa2154
# bad: [49f23a34bc2c03ac257963f5820fa9a495a060f0] source b92813d9b8b09604ecf7a9adc60f360f3bde140d
git bisect bad 49f23a34bc2c03ac257963f5820fa9a495a060f0
# good: [6abad4b33c5d7128f28b4d3e72bcb6d0064c7680] source ca7bffb060ae50331700b79aad8885b66b9f35f2
git bisect good 6abad4b33c5d7128f28b4d3e72bcb6d0064c7680
# bad: [e1aa5ab4de194242e71c1798d0dc6ab7ea869f7c] source 980e40304fa40a671624c5b4a8ec55d515f55dab
git bisect bad e1aa5ab4de194242e71c1798d0dc6ab7ea869f7c
# good: [24b10e07c4c0e9f0e0c5b9ed7e8ce0db29dcc3be] source 23916dba4343c27503be4e84f2746461f55c056f
git bisect good 24b10e07c4c0e9f0e0c5b9ed7e8ce0db29dcc3be
# bad: [d4a88ff22e4969fcf86f520aa194e09d85202a6b] source 6682a47deea5523b58dca37976f0f0fb30fb0a11
git bisect bad d4a88ff22e4969fcf86f520aa194e09d85202a6b
# good: [cac165c939c0094279cfea2922f81fd895c20aba] source 49181f4b2f3cc1eeb6d0ed0ad317c6f314bb5eba
git bisect good cac165c939c0094279cfea2922f81fd895c20aba
# bad: [2f237df2b28a3d78901d47a4d5ead561751ee742] source d2c7136158ce4163a03c14621cab26481e5fed96
git bisect bad 2f237df2b28a3d78901d47a4d5ead561751ee742
# bad: [909daec7c7fa8c20d9cadfdfed1236fdb5680e59] source 961ba62df045473e5793d9e103be86eaad8d9575
git bisect bad 909daec7c7fa8c20d9cadfdfed1236fdb5680e59
# good: [0ebf00955eff228dadaad0a565726bb908efc05f] source 6673aa3fefad3b64469e3c6457161e09f6c27f5f
git bisect good 0ebf00955eff228dadaad0a565726bb908efc05f
# first bad commit: [909daec7c7fa8c20d9cadfdfed1236fdb5680e59] source 961ba62df045473e5793d9e103be86eaad8d9575
Comment 1 NISZ LibreOffice Team 2019-02-22 13:07:51 UTC
Created attachment 149528 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2019-02-22 13:08:12 UTC
Created attachment 149529 [details]
The original file.
Comment 3 raal 2019-02-22 17:36:49 UTC
Confirm with Version: 6.3.0.0.alpha0+
Build ID: 465939feb0e9c382e5581b53b72008979ece4807
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 

Adding cc to Miklos Vajna, regression from his commit.
Comment 4 Dieter 2019-02-24 20:48:13 UTC
(In reply to raal from comment #3)
> Confirm with Version: 6.3.0.0.alpha0+

=> NEW
Comment 5 Xisco Faulí 2019-03-14 20:41:43 UTC
Adding Cc: to Miklos Vajna
Comment 7 Xisco Faulí 2019-03-28 13:28:27 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: e74de110d16c95414fac7541c8fe6541d4597113
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 8 Miklos Vajna 2019-08-06 12:07:57 UTC
*** Bug 113742 has been marked as a duplicate of this bug. ***