Bug Hunting Session
Bug 123666 - File open/save dialog size too small on Manjaro/KDE
Summary: File open/save dialog size too small on Manjaro/KDE
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE File-Dialog
  Show dependency treegraph
 
Reported: 2019-02-23 16:19 UTC by Dr. Martinus
Modified: 2019-05-21 11:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Martinus 2019-02-23 16:19:16 UTC
Description:
Whenever I open the file dialog to open a document or to save a document, the dialog is so small that it's hardly possible to read filenames. Every time I resize it, yet the next time it's again far too small. It seems to use the KDE file dialog, and I was looking if there is an option to use LO's own file dialog, but didn't find it. 

Steps to Reproduce:
1. Start LO
2. click on open a document
3.

Actual Results:
the file dialog opens, but it's too small, so that navigation and reading file names is quite difficult.

Expected Results:
the file dialog should open in the same size in which it was used the last time (LO used to do that before the last update).


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument, Calc, Base, Draw, Impress

OS: Manjaro Linux (All)
OS is 64bit: yes

Information from Help/About LibreOffice:

Version: 6.1.5.2
Build-ID: 6.1.5-2
CPU-Threads: 6; BS: Linux 4.4; UI-Render: Standard; VCL: gtk3_kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 1 Vera Blagoveschenskaya 2019-02-26 07:57:50 UTC
Hello, 
I've checked for x64 ALT Linux (started LO with kde4/kde5) - sizes of the dialogs are normal for me.

Can't reproduce for

Version: 6.1.6.0.0+
Build ID: 2ab2280f21fa491154e17c303dc70fcf059123b3
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2019-02-13_11:49:06
Locale: ru-RU (ru_RU.UTF-8); Calc: group threaded

Can't reproduce for

Version: 6.3.0.0.alpha0+
Build ID: 4187b2beaa3d1294cd5c76ec0b662f3f4fadc421
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-02-25_07:04:36
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Andre Klapper 2019-02-28 14:05:06 UTC
Dr. Martinus: Did you file a bug report in Manjaro's issue tracker to make sure that this is not a bug in Manjaro but in upstream LibreOffice code? If so, please provide a link to that bug report. Thanks.
Comment 3 Dr. Martinus 2019-02-28 17:39:48 UTC
Sorry, I didn't, i don't find a bug or issue tracker for Manjaro...
Comment 4 Dr. Martinus 2019-02-28 17:48:50 UTC
Well, i just posted it in the manjaro forum.
Comment 5 Michael Weghorn 2019-04-23 07:02:48 UTC
I cannot reproduce with

Version: 6.3.0.0.alpha0+
Build ID: aba66a9965c68ad56bbc52a334f440edc9a946b4
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3_kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

The initial description mentions that this is with the gtk3_kde5 VCL plugin.

This sounds very much like the lo_kde5filepicker process doesn't save its state in your case. A similar issue was observed that is fixed with https://gerrit.libreoffice.org/#/c/70834/ on master (i.e. the current development version to become LibreOffice 6.3).

Can you please check whether the selected view is also not remembered in your case? To do so, click on the "Options" icon in the file dialog and select "View" and another one than currently selected. Is that remembered when you open the file dialog next time or is it set back to the one that was there previously?
Comment 6 Michael Weghorn 2019-05-21 11:23:18 UTC
(In reply to Michael Weghorn from comment #5)
> This sounds very much like the lo_kde5filepicker process doesn't save its
> state in your case. A similar issue was observed that is fixed with
> https://gerrit.libreoffice.org/#/c/70834/ on master (i.e. the current
> development version to become LibreOffice 6.3).

I'm pretty confident that the cause for this bug has been fixed by the above commit, so I'm closing this as WORKSFORME.

Should the problem still be there with LibreOffice 6.3 (there is an alpha version that can be used for testing), please reopen this bug report.