Bug Hunting Session
Bug 123708 - EDITING Calc crashes when trying to move part of an array
Summary: EDITING Calc crashes when trying to move part of an array
Status: RESOLVED DUPLICATE of bug 121949
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-02-25 19:37 UTC by justus.croskery
Modified: 2019-02-26 15:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Select cells c2-c4 and try to drag them (8.23 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-02-25 19:37 UTC, justus.croskery
Details

Note You need to log in before you can comment on or make changes to this bug.
Description justus.croskery 2019-02-25 19:37:48 UTC
Created attachment 149584 [details]
Select cells c2-c4 and try to drag them

In LibreOffice Calc version 6.2.0.3, when you select part of an array (returned by a function) and try to drag it, LibreOffice will crash.
Comment 1 raal 2019-02-25 21:58:17 UTC
Confirm with Version: 6.3.0.0.alpha0+
Build ID: 465939feb0e9c382e5581b53b72008979ece4807
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 2 raal 2019-02-25 22:11:09 UTC
This seems to have begun at the below commit.
Adding Cc: to Luboš Luňák ; Could you possibly take a look at this one?
Thanks

a79e88101e6ecc177dd9de08f7c5fa0fd4a9843b is the first bad commit
commit a79e88101e6ecc177dd9de08f7c5fa0fd4a9843b
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Oct 10 13:22:44 2018 +0200

    source sha:79449d73900d7a9bf061244d76f5f8eecc441198

author	Luboš Luňák <l.lunak@collabora.com>	2018-10-01 14:26:57 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2018-10-10 13:01:59 +0200
commit	79449d73900d7a9bf061244d76f5f8eecc441198 (patch)
tree	e85f9bc29941cbf5e5ccb858ee4703ae67d00810
parent	b1721b04d8a921a69230927cd7995d8c5d8f5fe2 (diff)
make VLOOKUP in Calc thread-safe
Comment 3 Hiromi Kuramoto 2019-02-26 05:35:37 UTC
I confirmed the bug in my environment

with:
Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
CPU threads: 4; OS: Mac OS X 10.12.5; UI render: default; VCL: osx; 
Locale: en-US (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Julien Nabet 2019-02-26 13:32:53 UTC
I may be wrong but it may be a dup of tdf#121949

If it's the case, there's a patch on review here:
https://gerrit.libreoffice.org/68350
Comment 5 justus.croskery 2019-02-26 15:21:20 UTC
I would say this is a dupe of tdf#122550 and therefore also a dupe of tdf#121949. Also, both this bug and tdf#121949 were both introduced at the same commit. I'm closing this as a duplicate of tdf#121949.

*** This bug has been marked as a duplicate of bug 121949 ***