Download it now!
Bug 123744 - kde5: Can't drag'n'drop text from text editor to Writer
Summary: kde5: Can't drag'n'drop text from text editor to Writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-02-27 15:37 UTC by Michael Weghorn
Modified: 2019-06-15 22:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2019-02-27 15:37:55 UTC
Version: 6.3.0.0.alpha0+
Build ID: d34c0852d73b1b02115cc6c469106fabd057dbb7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

0) Start a text editor (e.g. Kate) and type some text
1) start LibreOffice Writer
2) select the text in the text editor
3) press the left mouse button and try to drag and drop the text to the Writer document

Result: No text is inserted when the mouse button is released over the Writer document.

Expected result: The text that was drag'n'dropped should be inserted (copied) into  the Writer document.

Note: This is specific to the qt5/kde5 VCL plugin. It works e.g. when using the gtk3 VCL plugin instead.
Comment 1 Buovjaga 2019-02-27 17:59:31 UTC
Repro.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 1663b1e8233db6c6d1c2b35639ad984961084009
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 26 February 2019
Comment 2 Jan-Marek Glogowski 2019-06-15 22:32:27 UTC
Quite probably fixed together with bug 122239. Can't reproduce anymore.
Comment 3 Michael Weghorn 2019-06-15 22:54:24 UTC
Verified it works with

Version: 6.4.0.0.alpha0+
Build ID: 77a3c443d35c7d966217f02ea9189cb1819c7828
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded