Bug 123815 - Import from LWP files cause "General input/output error."
Summary: Import from LWP files cause "General input/output error."
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.1.6 target:6.2.3
Keywords: bibisected, bisected, regression
: 48420 (view as bug list)
Depends on:
Blocks: LWP
  Show dependency treegraph
 
Reported: 2019-03-03 11:48 UTC by Naruhiko Ogasawara
Modified: 2019-04-12 03:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
a LWP file can not be opened (51.34 KB, application/vnd.lotus-wordpro)
2019-03-03 11:49 UTC, Naruhiko Ogasawara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2019-03-03 11:48:47 UTC
Description:
Importing from some kind of LWP files (see attached) pops up "General input/output error."

Steps to Reproduce:
1. Launch LibreOffice
2. File > Open > open an attached LWP file

Actual Results:
A dialog "General error.  General input/output error." is popped up, and can't be opened.


Expected Results:
Opened as a writer document correctly



Reproducible: Always


User Profile Reset: Yes



Additional Info:
- Ubuntu 18.10
  - Version: 6.2.0.3 (AppImage)
    Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
  - Version: 6.3.0.0.alpha0+
    Build ID: 9b6a377e770cc6455feac0b83da8d9639926b993
- Windows 10 home 64bit (1809)
  - Version: 6.2.0.3 64bit

AOO 4.5 can open it correctly.
Comment 1 Naruhiko Ogasawara 2019-03-03 11:49:54 UTC
Created attachment 149691 [details]
a LWP file can not be opened
Comment 2 raal 2019-03-03 14:34:44 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

6732187a5e96aae5874511c3cb7f74a04eaee660 is the first bad commit
commit 6732187a5e96aae5874511c3cb7f74a04eaee660
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Jun 20 19:15:37 2017 +0200

    source sha:18d636063fd7be165e7888af49372a6e2b851776

author	Caolán McNamara <caolanm@redhat.com>	2017-06-19 09:46:31 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2017-06-19 13:32:01 +0200
commit	18d636063fd7be165e7888af49372a6e2b851776 (patch)
tree	7e272d9a34aa715af3b19faef384d2f3b64e229a
parent	0df3de34ad775d6d3c49036c03c3f6dad7141536 (diff)
ofz: use OString instead of bare char*
Comment 3 Julien Nabet 2019-03-04 20:25:51 UTC
Raal: I gave a try by reverting the commit you indicated + fix conflict, there's still the error.
Are you sure about your bibisect?
Comment 4 raal 2019-03-04 20:59:01 UTC
(In reply to Julien Nabet from comment #3)
> Raal: I gave a try by reverting the commit you indicated + fix conflict,
> there's still the error.
> Are you sure about your bibisect?

Hello Julien, I bisected it with bibisect-linux-64-6.0 and checked again now:
git checkout 6732187a5e96aae5874511c3cb7f74a04eaee660 -> bug is here
git checkout HEAD~1 -> bug is not here

Maybe my bisect is bad for another reason like bibisect repo, my enviroment etc. Feel free remove bisected keyword. I'll try bisect it on windows later.
Comment 5 Caolán McNamara 2019-03-05 13:05:15 UTC
my commit there is wrong, but there must be another thing wrong
Comment 6 Caolán McNamara 2019-03-05 13:24:06 UTC
hmm, was this document blank in versions where it didn't report general input/output error ? i.e. appeared as an empty document ?

I think my commit there is wrong, *but* that this document never worked anyway because its an unsupported version and now that is reported as a failure rather than as silently producing an empty document
Comment 7 raal 2019-03-05 13:30:47 UTC
(In reply to Caolán McNamara from comment #6)
> hmm, was this document blank in versions where it didn't report general
> input/output error ? i.e. appeared as an empty document ?
> 

Yes. In versions where I tested it, the document was blank.
Comment 8 Caolán McNamara 2019-03-05 13:54:20 UTC
Yeah, that's it then. The document was never openable, just failed silently. *But* the bisected commit was wrong and is corrected in https://gerrit.libreoffice.org/#/c/68745/
Comment 9 Julien Nabet 2019-03-05 13:59:20 UTC
Naruhiko: when you tell "AOO 4.5 can open it correctly", what does it contain?
Comment 10 Commit Notification 2019-03-05 21:10:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/efbd217afc52390138195e06e96ef9c8f10bf37b%5E%21

Resolves: tdf#123815 null terminator included in string

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-03-06 10:32:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/cd376726cc8dad65d246493fee233c8018123bf1%5E%21

Resolves: tdf#123815 null terminator included in string

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-03-06 10:33:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6c0a06c550f9fcd9a2b107954a4eb466c032ef4a%5E%21

Resolves: tdf#123815 null terminator included in string

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Caolán McNamara 2019-03-07 08:55:55 UTC
I'll call this fixed, cause there was a bug in the mentioned commit. But it doesn't seem to matter for this specific unsupported document version and the document is correctly reported as failing to open in any case
Comment 14 Kumāra 2019-04-12 03:02:17 UTC
*** Bug 48420 has been marked as a duplicate of this bug. ***