Download it now!
Bug 123841 - Choosing an unfilled rectangle (or circle or square) draws a filled rectangle
Summary: Choosing an unfilled rectangle (or circle or square) draws a filled rectangle
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0
Keywords: difficultyBeginner, easyHack
: 121360 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-04 13:49 UTC by Laulo7
Modified: 2020-01-20 06:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laulo7 2019-03-04 13:49:10 UTC
Description:
Choosing an unfilled rectangle (or circle or square) draws a filled rectangle.

Steps to Reproduce:
1.Click the unfilled rectangle button
2.Draw the rectangle

Actual Results:
Rectangle is filed

Expected Results:
Rectangle is unfilled


Reproducible: Always


User Profile Reset: No



Additional Info:
Functional under the previous version of Libreoffice 6


Version: 6.2.0.3
Build ID: 98c6a8a1c6c7b144ce3cc729e34964b47ce25d62
Threads CPU : 4; OS : Windows 6.1; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded
Comment 1 Durgapriyanka 2019-03-04 15:10:26 UTC
Thank you for reporting the bug. I can confirm the bug is present

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 2 Regina Henschel 2019-03-05 13:18:29 UTC
The style "Object without fill" is empty. The error is in https://opengrok.libreoffice.org/xref/core/sd/source/core/drawdoc4.cxx

Compare part '// Default > Object without filling' starting in line #247 with the part '// Default > Object no fill no line' starting in line #254.
Comment 3 Regina Henschel 2019-03-05 13:25:51 UTC
@Laulo7: Workaround: In tab Area in style 'Object without fill' set the color filling explicitly to 'None'. To get it correct for new documents make the change with an empty document and set it in File > Templates > 'Save as template' as new default template.
Comment 4 Buovjaga 2019-04-04 19:10:21 UTC
I assume caused by the fix to bug 94369
Comment 5 Regina Henschel 2019-05-12 12:43:08 UTC
*** Bug 121360 has been marked as a duplicate of this bug. ***
Comment 6 Shivam Kumar Singh 2020-01-15 15:29:07 UTC
Assigned to shivamhere247@gmail.com
Comment 7 Shivam Kumar Singh 2020-01-15 15:48:31 UTC
I would like to take on this bug . I think simply adding 
pISet->Put(XFillStyleItem(drawing::FillStyle_NONE));
 to the " Default > Object without filling " in line 252 in /sd/source/core/drawdoc4.cxx should do .
Comment 8 Shivam Kumar Singh 2020-01-15 16:53:47 UTC
Can someone mentor me on this ?
Comment 9 Regina Henschel 2020-01-15 17:05:11 UTC
Do you have already a working build?
Comment 10 Buovjaga 2020-01-15 17:20:15 UTC
(In reply to Regina Henschel from comment #9)
> Do you have already a working build?

Yes, he has. Let's add him to Cc.
Comment 11 Commit Notification 2020-01-18 16:21:51 UTC
Shivam Kumar Singh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4efe996eb593387e0a5e7a58f4e29b32bdf92098

tdf#123841 unfilled rectangles would make filled rectangles

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.