Bug 94369 - Default set of Impress graphic styles
Summary: Default set of Impress graphic styles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: ImpressDraw-Styles Impress-UX
  Show dependency treegraph
 
Reported: 2015-09-20 03:45 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-09-18 06:53 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of current styles (105.75 KB, image/png)
2018-08-28 08:17 UTC, Heiko Tietze
Details
Sample file with current styles (11.97 KB, application/vnd.oasis.opendocument.graphics)
2018-08-28 08:17 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-09-20 03:45:27 UTC
Similar to proposing a new set of default cell styles for Calc (bug 90937), a new set of default graphic styles are needed for Impress, which will also be available in Draw.

The list of graphic styles can be broken down into what i would classify as shape styles and textbox styles. Shape styles focus on line and area properties but can also include text properties, while textbox style focus on text properties, but can also include line and area properties.

Shape Styles (atleast how i see it :D)
-------------------

== Line Styles ==

Dimension Line: Used by 'Dimension Line' and is a line style with a black line with start and end arrows

Object without fill: Used by line objects like 'Line', 'Line Ends with Arrow', and 'Line 45*' and is a line style with no fill and black line.

Object with arrow: Thick black line with start arrow

== Non-Line Styles ==

Object with no fill and no line: Quite useless as a shape style unless it is meant to intentionally hide an shape from view

Object with shadow: blue fill, dark blue border, and shadow


Textbox Styles
-------------------

== Text-Only ==

First line indent: 0.24", 18pt (inherited)
Heading: 24pt
Heading 1: 18pt bold
Heading 2: 14pt bold italics
Text: no fill, no line, 18pt (inherited)
Text body: no fill, no line, 16pt
Text body justified: no fill, no line, justified, 18pt (inherited)
Title: no fill, no line, 44pt

== Text and Shape ==

Title1: green fill, no line, 24pt, shadow
Title2: light orange fill, blue border, 36pt, centered, shadow

-------------------

All the styles directly inheriting from Default, so it might be useful to have some styles inheriting from others. But the main focus that i think that is needed is to improve the shape styles with some good defaults.
Comment 1 Robinson Tryon (qubit) 2016-08-25 05:38:54 UTC Comment hidden (obsolete)
Comment 2 Heiko Tietze 2017-01-17 16:36:54 UTC
Topic for 5.4?
Comment 3 Yousuf Philips (jay) (retired) 2017-01-19 09:51:33 UTC
(In reply to Heiko Tietze from comment #2)
> Topic for 5.4?

Why not. :D
Comment 4 Roman Kuznetsov 2018-06-22 14:52:17 UTC
Heiko, do will we do any new styles for shapes?
Comment 5 Heiko Tietze 2018-06-22 16:05:10 UTC
(In reply to kompilainenn from comment #4)
> Heiko, do will we do any new styles for shapes?

We do have new drawing styles with 6.1 - your contribution. Beyond that nothing is planned.
Comment 6 Roman Kuznetsov 2018-06-22 16:27:18 UTC
(In reply to Heiko Tietze from comment #5)
> (In reply to kompilainenn from comment #4)
> > Heiko, do will we do any new styles for shapes?
> 
> We do have new drawing styles with 6.1 - your contribution. Beyond that
> nothing is planned.

So may be close this bug?
Comment 7 Heiko Tietze 2018-06-22 20:44:37 UTC
(In reply to kompilainenn from comment #6)
> So may be close this bug?

Sounds like a plan. If the user needs more styles it's easy to add some.
Comment 8 Heiko Tietze 2018-06-27 08:53:07 UTC

*** This bug has been marked as a duplicate of bug 117455 ***
Comment 9 Yousuf Philips (jay) (retired) 2018-07-06 18:47:42 UTC
Bug 117455 adds a few shape styles but no textbox styles.
Comment 10 Heiko Tietze 2018-07-06 20:31:39 UTC Comment hidden (obsolete)
Comment 11 Heiko Tietze 2018-07-06 20:36:03 UTC
(In reply to Heiko Tietze from comment #10)
> Jay, please give a reason why you reopen the ticket.

Ignore this comment, missed comment 9. OTOH I disagree with your statement; texbox styles aren't primary draw styles and we have a few of that. Focus of drawing styles must not be to make text formatting as easy as possible.

Up to QA/design team to decide.
Comment 12 andreas_k 2018-08-07 21:23:15 UTC
I hope that draw can get some styles for text. As draw is use also for pdf editing or write brochures I hope to get some of the writer styles.

I'm thinking of

- Text Body
- Title
- Heading 1
- Heading 2
- Heading 3
- Quotations
- Preformatted Text
- Bullet List
- Number List

all of this elements are available in the writer styles menubar.

In addition I hope that the drawing styles will be available in writer to.
Comment 13 Heiko Tietze 2018-08-16 12:56:56 UTC
We discussed the request in the design. Ideally, we would have the same edit engine for Writer and Draw/Impress, which results in one set of styles. However, drawing styles are handled differently and, for example, are "burned-in" when copying objects from Draw to Writer. So it makes not much sense to provide all styles. On the other hand, it makes sense to have a few more, rather textual styles such as Title, Heading, and Text focusing on A0 posters generation. I will make a proposal.
Comment 14 Heiko Tietze 2018-08-28 08:16:34 UTC
What we have under "Default" is
Title: no line/arrow; no area; Liberation Sans 44; Spacing 0/0
Text: no line/arrow; no area; Liberation Sans 18; Spacing 0/0
Object without fill: continuous,black,0"/no arrow; no area; Liberation Sans 18; Spacing 0/0
Object with no fill and no line: no line/arrow; no area; Liberation Sans 18; Spacing 0/0
Text: no line/arrow; no area; Liberation Sans 24; Spacing 0.17"/0.08"
Dimension Line: continuous,black,0"/arrow 0.08"; no area; Liberation Sans 12; Spacing 0/0

Default is continuous, Dark Blue 1, 0"; area #729fcf; Liberation Sans 18; Spacing 0/0

Introduced with last release was Filled and Outlined.

I suggest we go with (- for what remains more or less as today, + for additional entries):

Default (this likely cannot be changed)
- Object without fill (no line, no area, Sans 18)
- Object with fill (black, #729fcf, Sans 18)
Text  (no line, no area, Sans 18)
 + A4  (inherited)
 -- Title (inherited, Sans 44)
 -- Heading (inherited, Sans 24)
 -- Text  (inherited)
 + A0 (inherited, Sans 48)
  ++ Title (inherited, Sans 96)
  ++ Heading (inherited, Sans 72)
  ++ Text (inherited, Sans 48)
Graphic (same as Default)
 ++ Shapes (inherited)
  --- Filled 
   ---- (Blue, Green, Red, Yellow as today)
  --- Outlined
   ---- (Blue, Green, Red, Yellow  as today)
 ++ Lines (continuous,black,0", no arrow, inherited)
  --- Dimension Line
  +++ Black Line (inherited)
  +++ Dashed Line (dashed, inherited)

Or is this too much organization? I inherit a lot without modification since users IMHO don't take the organizing items for styling.
Comment 15 Heiko Tietze 2018-08-28 08:17:05 UTC
Created attachment 144496 [details]
Screenshot of current styles
Comment 16 Heiko Tietze 2018-08-28 08:17:30 UTC
Created attachment 144497 [details]
Sample file with current styles
Comment 17 Heiko Tietze 2018-09-13 17:32:58 UTC
Patch is here https://gerrit.libreoffice.org/#/c/60444/
Comment 18 Commit Notification 2018-09-18 06:52:04 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=99102d4263189d347c7a7d0df8fd782e8c4c8ad5

tdf#94369 - Default set of Impress graphic styles

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.