Bug 90937 - Default set of calc cell styles
Summary: Default set of calc cell styles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
: 92968 96352 (view as bug list)
Depends on: 103331 105429 103330 103332 103380
Blocks: Calc-Styles
  Show dependency treegraph
 
Reported: 2015-04-29 15:18 UTC by Yousuf Philips (jay)
Modified: 2017-05-30 05:47 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
excel 2013 cell styles (36.08 KB, image/png)
2015-04-29 15:18 UTC, Yousuf Philips (jay)
Details
Calc default styles proposal (34.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-17 19:11 UTC, mahfiaz
Details
A cleaned version of style definitions XML (3.08 KB, text/xml)
2015-06-17 19:46 UTC, mahfiaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2015-04-29 15:18:44 UTC
Created attachment 115188 [details]
excel 2013 cell styles

Calc presently has a default set of 5 cell styles most of which are not very useful.

Default - Liberation Sans 10pt; Borders: 1pt Content Spacing; Format: General
 Heading - 16pt, Bold, Italics, Horizontal Center
  Heading 1 - Text Orientation: 90 degrees
 Result - Bold, Italics, Underline
  Result 2 - Format: Currency with Red Highlight

During a survey that was run about improving Calc months ago ( http://user-prompt.com/how-do-you-want-libreoffice-calcs-toolbar-configured/ ), one of the most asked feature improvements requested was for better usage of styles, but this cant be achieved without a good set of default styles.

This issue was briefly discussed on redmine ( https://redmine.documentfoundation.org/boards/1/topics/493 ) so i've opened this bug report to have a record in bugzilla and also link to a google docs spreadsheet which i've begun working on regarding this issue with others.

https://docs.google.com/spreadsheets/d/1Bt2Gr0JslOLL86xb-bCl76mji5AhHT_8VI-5Wp5Qyq0/edit?usp=sharing

This file and additional ones related to this topic can be found in this google docs folder.

https://drive.google.com/folderview?id=0B6qJrVIa0SAlfjVOLUhUV2pNcnI0MWpxYUNwX3VKajhsY0VGYjdkaGVpbE1fWDBrWGdxdGc&usp=sharing

Once we have a good set, it would be useful to show the 'Apply Style' drop down menu in the formatting toolbar once it functions properly, as cell backgrounds and borders arent currently rendered and there are some other bugs (e.g. bug 90931, bug 90934)
Comment 1 Yousuf Philips (jay) 2015-04-29 15:26:52 UTC
Setting NEW as ux-advise enhancement.
Comment 2 Yousuf Philips (jay) 2015-05-06 18:05:21 UTC
Kendy stated that the current cell styles are hardcoded into the following function ScStyleSheetPool::CreateStandardStyles()

http://cgit.freedesktop.org/libreoffice/core/tree/sc/source/core/data/stlpool.cxx#n275
Comment 3 mahfiaz 2015-06-17 19:11:40 UTC
Created attachment 116607 [details]
Calc default styles proposal
Comment 4 mahfiaz 2015-06-17 19:24:20 UTC
So the design team just agreed that the "Calc default styles proposal" is what we would like to see as the default styles in Calc.

I feel pretty good about the outcome, I think it looks nice and functional.
* it uses colors from the default palette
* showcases the use of styles
* works in grayscale print (except for the "Warning" style)
* previously present styles "Result" and "Result 1" would be removed (I think only engineers use such styles and underline button works just fine for us)
Comment 5 mahfiaz 2015-06-17 19:46:01 UTC
Created attachment 116608 [details]
A cleaned version of style definitions XML
Comment 6 Yousuf Philips (jay) 2015-06-28 00:49:11 UTC
CCing markus on this bug, as he said he would implement this once the design team had finalized a styles xml file, we we have just completed.
Comment 7 raal 2015-07-29 17:03:54 UTC
*** Bug 92968 has been marked as a duplicate of this bug. ***
Comment 8 Yousuf Philips (jay) 2015-09-29 12:58:29 UTC
This is a status update:

At the beginning of the month, moggi asked me to provide a list of all possible cell formatting features that maybe used, as he would need to implement them in orcus ( https://gitlab.com/orcus/orcus/blob/master/README.md ), as all he had presently implemented was for the current set of styles we've provided ( font properties, background fill, borders ). This was the list i provided to him.

1) Font: name, size, color, bold, italics, underline
2) number format
3) border line arrangement and style
4) background color 

Moggi has stated to me today that unfortunately he doesnt have enough time to implement this in 5.1, so he's postponed this for 5.2.
Comment 9 Maxim Monastirsky 2015-12-09 11:40:53 UTC
*** Bug 96352 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) 2016-08-13 22:00:07 UTC
This is a status update:

Moggi said to me a few months ago that he doesnt have time to implement this feature within Orcus, which would then make the feature available within Calc, so he had setup a GSoC idea for the work which he would mentor if a student took up the task.

https://wiki.documentfoundation.org/Development/GSoC/Ideas#Support_ODF_styles_in_orcus
Comment 11 Yousuf Philips (jay) 2016-09-06 19:09:04 UTC
Status Update:

A GSoC student took on the project and it was completed. Moggi stated that he has to fix some test failures and then we can begin integrating the cell styles in.
Comment 12 Commit Notification 2016-10-02 13:54:51 UTC
Jaskaran Singh committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06f319937187f76ee402d53b3baa78c391c2af19

tdf#90937 Add a set of cell styles to calc

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Markus Mohrhard 2016-10-16 07:39:10 UTC
I suppose this can be considered closed. Please improve the text in the 5.3 release notes about the feature.
Comment 14 Commit Notification 2016-10-19 21:42:03 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e459881f0c29398052b9ce28354f2668163626af

tdf#90937 Correct cell style names that are missing a space

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Kevin Suo 2016-10-20 07:58:22 UTC
I suggest that the border of style "Note" be changed to 0.75 pt. Currently it's 0.06pt as I can see in the source code of the commit message.

Borders below 0.75pt are showing dashed when save as xlsx, because of the bug as discussed in bug 79787.
Comment 16 Commit Notification 2016-10-21 10:32:02 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c18e169ce817f940bede186166540913cb564b4c

tdf#90937 Adjust Note cell style border width and color

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.