Bug 123872 - help/languages.js is not valid Javascript, breaks browser-based docs
Summary: help/languages.js is not valid Javascript, breaks browser-based docs
Status: RESOLVED DUPLICATE of bug 121532
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-05 14:19 UTC by jsd.libreoffice
Modified: 2019-03-05 14:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jsd.libreoffice 2019-03-05 14:19:40 UTC
First: thanks for LO, great work.

On a fresh install of LO 6.2.0 on MacOS 10.13.6, I clicked on a Help icon, which opened a browser at URL file:///Applications/LibreOffice.app/Contents/Resources/help/index.html
However the displayed page was blank.  Browser console revealed an error in languages.js: "Unexpected token: var"

Discovered languages.js in above dir was not valid JS; it had "-n" at the start of each line and no commas between the language ID strings.

The installed languages.js looked like this:
  -n var languagesSet = new Set([
  -n 'en-US'
  -n 'am'
...etc

It clearly was intended to look like this:
  var languagesSet = new Set([
  'en-US',
  'am',
  'ar',
...etc

A quick edit to the second style fixed this and docs in browser worked fine thereafter.
Comment 1 Olivier Hallot 2019-03-05 14:28:25 UTC

*** This bug has been marked as a duplicate of bug 121532 ***