Bug Hunting Session
Bug 121532 - LO62b1: on macOS local help opens an empty page in default browser
Summary: LO62b1: on macOS local help opens an empty page in default browser
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Mac OS X (All)
: highest critical
Assignee: Stephan Bergmann
URL:
Whiteboard: target:6.3.0 target:6.2.1
Keywords: bibisected, bisected, regression
: 123246 123872 124715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-19 22:21 UTC by Martin Srebotnjak
Modified: 2019-04-14 22:27 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2018-11-19 22:21:19 UTC
Description:
Selecting help in LO (Help > LibreOffice Help) it opens an empty page in browser (as if it does not exist).
In LO62b1 with Slovenian language pack it tries to open this page:
file:///Applications/LibreOfficeDev.app/Contents/Resources/help/index.html?Target=swriter/.uno%3AHelpIndex&Language=sl&System=MAC&Version=6.2

But this opens an empty page.

Steps to Reproduce:
1. Open LO
2. Open the help page from Help menu
3.

Actual Results:
Empty help page in system-default browser.

Expected Results:
Contextual help page in system-default browser.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2018-11-28 08:59:40 UTC
Confirming

I see the following link loaded in Firefox with dailybuild from end of last week.

file:///Applications/LibreOfficeDev.app/Contents/Resources/help/index.html?Target=swriter/.uno%3AHelpIndex&Language=en-US&System=MAC&Version=6.3


Version: 6.3.0.0.alpha0+
Build ID: 284dd58e326e61a5d84bde367e1e4873dd738c76
CPU threads: 4; OS: Mac OS X 10.14.1; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-11-22_23:09:13
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2019-01-08 16:24:09 UTC
So, the help is there, because it works with

file:///Applications/LibreOffice%206.2.0.1.app/Contents/Resources/help/en-US/text/shared/guide/startcenter.html?System=MAC&DbPAR=WRITER

but it tries to open

file:///Applications/LibreOffice%206.2.0.1.app/Contents/Resources/help/index.html?Target=swriter/sfx/ui/startcenter/open_all&Language=en-US&System=MAC&Version=6.2

@Olivier, do you know why is it happening ?
Comment 3 Xisco Faulí 2019-01-08 16:26:03 UTC
On windows, it uses

file:///C:/Program%20Files/LibreOffice/help/es/text/shared/guide/startcenter.html?System=WIN&DbPAR=WRITER&HID=sfx/ui/startcenter/open_all#bm_id1022200910595546
Comment 4 Xisco Faulí 2019-02-08 17:07:40 UTC
*** Bug 123246 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2019-02-08 17:08:14 UTC
I believe the severity should be increased...
Comment 6 Xisco Faulí 2019-02-13 00:30:48 UTC
LibreOffice 6.1.5.2 opens file:///Applications/LibreOffice%206.1.5.2.app/Contents/Resources/help/en-US/text/shared/guide/startcenter.html?System=MAC&DbPAR=WRITER#bm_id1022200910595546

while LibreOffice 6.2.0.2 opens 
file:///Applications/LibreOffice%206.2.0.2.app/Contents/Resources/help/index.html?Target=swriter/sfx/ui/startcenter/open_all&Language=en-US&System=MAC&Version=6.2.
Changing it to 
file:///Applications/LibreOffice%206.2.0.2.app/Contents/Resources/help/en-US/text/shared/guide/startcenter.html??Target=swriter/sfx/ui/startcenter/open_all&Language=en-US&System=MAC&Version=6.2 fixes the issue...
Comment 7 Xisco Faulí 2019-02-13 13:54:35 UTC
I'm trying to bisect manually where the problem was introduced...
I've just checked in

Version: 6.2.0.0.alpha0+
Build ID: a85d3ba1c0de313b60324b9ecfa488bb99d69d06
CPU threads: 8; OS: Mac OS X 10.14.2; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: threaded

and the problem is already reproducible...
Comment 8 Xisco Faulí 2019-02-13 15:54:34 UTC
Not reproduced in

Version: 6.1.0.0.alpha1+
Build ID: 3a801799536e6870f2fb111b1cc00b9575a35a39
CPU threads: 8; OS: Mac OS X 10.14.2; UI render: default; 
Locale: en-US (en_ES.UTF-8); Calc: group
Comment 9 Xisco Faulí 2019-02-14 11:53:38 UTC
Finally I found the culplit

author	Jan Holesovsky <kendy@collabora.com>	2018-08-10 18:54:13 +0200
committer	Olivier Hallot <olivier.hallot@libreoffice.org>	2018-08-14 20:19:51 +0200
commit	45660fb701334609da077a00222a57d2fc252eb4 (patch)
tree	06ebdf0a9a83a3a6fa99c91f0638c86666d576ab
parent	daa131c420c640a66c36e69da58f7e6a9d9bd8f0 (diff)
help: Let's make the help urls more standard, and use ?Target=...&... form.

I reverted it locally yesterday, but a make clean it needed in order to apply the changes in help, sigh!

Adding Cc: to Jan Holesovsky
Comment 10 Stephan Bergmann 2019-02-15 08:56:59 UTC
Trying with en-US 6.2.0.3 downloaded from <https://www.libreoffice.org/download/download/>.  Once you have copied the LibreOffice.app from the downloaded *.dmg to your local disk (e.g., to /Applications/; there is a different failure when you start LO directly from the downloaded *.dmg, which I'll discuss in a follow-up issue):

Startcenter "Help - LibreOffice Help" opens <file:///Applications/LibreOffice.app/Contents/Resources/help/index.html?Target=swriter/.uno%3AHelpIndex&Language=en-US&System=MAC&Version=6.2> in the default browser (Safari here), but as an empty page.  In Safari (with "Show Develop menu in menu bar" enabled), "Develop - Show JavaScript Console" shows:

> SyntaxError: Unexpected keyword 'var'. Parse error.
> (anonymous function) — languages.js:1
> existingLang — help2.js:129

The issue appears to be the included LibreOffice.app/Contents/Resources/help/languages.js with the below broken content.  If I manually change the content of /Applications/LibreOffice.app/Contents/Resources/help/languages.js to the single line

  var languagesSet = new Set(['en-US']);

then Startcenter "Help - LibreOffice Help" opens <file:///Applications/LibreOffice.app/Contents/Resources/help/en-US/text/shared/main0108.html?System=MAC&DbPAR=WRITER&HID=.uno:HelpIndex#bm_id3149178> and shows help content regarding LO's "Help" menu.


The content of the broken included LibreOffice.app/Contents/Resources/help/languages.js  (i.e., with bad "-n " preceding most lines):

-n var languagesSet = new Set([
-n 'en-US'
-n 'am'
-n 'ar'
-n 'ast'
-n 'bg'
-n 'bn'
-n 'bn-IN'
-n 'bo'
-n 'bs'
-n 'ca'
-n 'ca-valencia'
-n 'cs'
-n 'da'
-n 'de'
-n 'dz'
-n 'el'
-n 'en-GB'
-n 'en-ZA'
-n 'eo'
-n 'es'
-n 'et'
-n 'eu'
-n 'fi'
-n 'fr'
-n 'gl'
-n 'gu'
-n 'he'
-n 'hi'
-n 'hr'
-n 'hu'
-n 'id'
-n 'is'
-n 'it'
-n 'ja'
-n 'ka'
-n 'km'
-n 'ko'
-n 'lo'
-n 'lt'
-n 'lv'
-n 'mk'
-n 'nb'
-n 'ne'
-n 'nl'
-n 'nn'
-n 'om'
-n 'pl'
-n 'pt'
-n 'pt-BR'
-n 'ro'
-n 'ru'
-n 'si'
-n 'sid'
-n 'sk'
-n 'sl'
-n 'sq'
-n 'sv'
-n 'ta'
-n 'tg'
-n 'tr'
-n 'ug'
-n 'uk'
-n 'vi'
-n 'zh-CN'
-n 'zh-TW'
]);
Comment 11 Stephan Bergmann 2019-02-15 09:21:27 UTC
should get fixed with <https://gerrit.libreoffice.org/67858 tdf#121532> "Don't use non-standard `echo -n`"
Comment 12 Commit Notification 2019-02-15 10:27:08 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/8986dec8229cf31ccfadb61e6e90c905f7033ac7%5E%21

tdf#121532 Don't use non-standard `echo -n`
Comment 13 Xisco Faulí 2019-02-15 13:17:20 UTC
Verified locally with a mac build

@Stephan, thanks for fixing this issue!!
Comment 14 Commit Notification 2019-02-15 13:19:24 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-1":

https://git.libreoffice.org/help/+/8339ecf401eb80f1d501d9d5d9e6de10908773cd%5E%21

tdf#121532 Don't use non-standard `echo -n`
Comment 15 Commit Notification 2019-02-15 13:20:50 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/help/+/18e278f7c01a22112d59d56e38794455e1166e41%5E%21

tdf#121532 Don't use non-standard `echo -n`
Comment 16 Martin Srebotnjak 2019-02-15 22:58:16 UTC Comment hidden (no-value)
Comment 17 Olivier Hallot 2019-03-05 14:28:25 UTC
*** Bug 123872 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2019-03-12 11:08:25 UTC
(In reply to Martin Srebotnjak from comment #16)
> How is this possible - I reported this error in November and yet LibreOffice
> 6.2 shipped in February without working help on one of the three supported
> OS' which is/should be a major blocker for any software release?
> Or is macOS not the supported OS anymore?

Please download LibreOffice 6.2.1.2 from https://www.libreoffice.org/download/download/. it's now fixed
Comment 19 Xisco Faulí 2019-04-14 22:27:09 UTC
*** Bug 124715 has been marked as a duplicate of this bug. ***