Bug Hunting Session
Bug 123880 - Opening xls file in previous versions of libre vs 6.2.0.3
Summary: Opening xls file in previous versions of libre vs 6.2.0.3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:xls, regression
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
 
Reported: 2019-03-05 17:47 UTC by Jared Neal
Modified: 2019-08-19 10:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
original file (44.73 KB, application/xml)
2019-03-05 17:49 UTC, Jared Neal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jared Neal 2019-03-05 17:47:43 UTC
Description:
I am not sure if there is a setting i need for formatting or if new libre calc is not formatting properly.

Steps to Reproduce:
1.download xls opens fine in 6.0.7.3 and 5.3.3.2
2.open same xls in 6.2.0.3 formats as a html. does not put data in cells.
3.

Actual Results:
download xls
open in 6.2.0.3
formatting is incorrect.

Expected Results:
It should populate the data as it does in version 6.0.7.3


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Jared Neal 2019-03-05 17:49:58 UTC
Created attachment 149754 [details]
original file

Please open this in version 6.0.7.3 = works correctly
please open this in version 6.2.0.3 = incorrect formatting
Comment 2 Roman Kuznetsov 2019-03-06 12:10:37 UTC
File opens as HTML in

Version: 6.2.1.1
Build ID: 757c58e8cb70b2982843211a54750fb3cd79acd5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

file doesn't open in

Version: 6.3.0.0.alpha0+
Build ID: d81a11220d76eeecac80b27b25a4576b6e78210b
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

with General error input/output.

but in

Версия: 5.2.7.2
ID сборки: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Потоков ЦП: 4; Версия ОС: Windows 6.1; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: group

file opens fine

Regression
Comment 3 raal 2019-03-06 14:27:38 UTC Comment hidden (obsolete)
Comment 4 Noel Grandin 2019-03-06 14:59:05 UTC
You'll need to bisect from before commit 7ea01578eed8459678369d0256de016930b3af40 where I messed up XLS import.

We are correctly detecting this as XLS, and we call into the ORCUS XLS filter, and then ORCUS complains with:

warn:sc:4715:4715:sc/source/filter/orcus/orcusfiltersimpl.cxx:75: Unable to load file via orcus filter! 'BLACK' is not a valid RGB color string.

So I suspect your bisect will come to back to whereever we introduced the orcus filter.

ORCUS appears to be complaining about the following stuff in the attached file:

   ss:Color="BLACK"

According to some microsoft docs:

"Specifies the color of this border. This value can be either a 6-hexadecimal digit number in "#rrggbb" format or it can be any of the Microsoft® Internet Explorer named colors (including the named Microsoft Windows® colors). This string can also be the special value of "Automatic." This string is case insensitive"

So it looks like orcus is missing out in this department, the relevant code in orcus lives at the repo at
    https://gitlab.com/orcus/orcus/
in the source file
   src/liborcus/spreadsheet_types.cpp
in function 
    to_color_rgb
Comment 5 Kohei Yoshida 2019-03-14 01:05:05 UTC
This is fixed on the orcus side at least.
Comment 6 Xisco Faulí 2019-03-14 20:29:18 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=152c79ee2be2374334202dc738a8f011e47845c7

author	Kohei Yoshida <kohei.yoshida@gmail.com>	2017-12-03 21:25:53 -0500
committer	Kohei Yoshida <libreoffice@kohei.us>	2017-12-18 02:30:39 +0100
commit	152c79ee2be2374334202dc738a8f011e47845c7 (patch)
tree	a9dca320422e3afa66f6ed94d0ef1b0ca5899027
parent	99210a149c859fcd683870b280adaeeffd1250e4 (diff)
Initial step on enabling the orcus-based Excel 2003 XML filter.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Kohei Yoshida
Comment 7 Kohei Yoshida 2019-03-15 12:17:37 UTC
@Xisco, isn't it what Noel already said in Comment 4?  What's the point of repeating who broke this over and over again?
Comment 8 Xisco Faulí 2019-03-18 19:16:53 UTC
(In reply to Kohei Yoshida from comment #7)
> @Xisco, isn't it what Noel already said in Comment 4?  What's the point of
> repeating who broke this over and over again?

Noel said: 'You'll need to bisect from before commit 7ea01578eed8459678369d0256de016930b3af40 where I messed up XLS import.' so that's what I did. On the other hand, it's good to have the commit's hash in the comment for future querys in Bugzilla
Comment 9 Kohei Yoshida 2019-08-15 13:00:41 UTC
Orcus has been upgraded on the master branch, and with that, this issue is now gone.
Comment 10 Xisco Faulí 2019-08-19 10:53:34 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: cbe9601e5972ec1c466311e0b148a9fbe8cda4d1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Kohei, thanks for fixing this issue!