Bug Hunting Session
Bug 123553 - Cannot open MSO XML file
Summary: Cannot open MSO XML file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 124580 (view as bug list)
Depends on:
Blocks: MSO-XML2003
  Show dependency treegraph
 
Reported: 2019-02-18 21:49 UTC by raal
Modified: 2019-08-19 11:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
xml file (25.39 KB, application/vnd.ms-excel)
2019-02-18 21:49 UTC, raal
Details
printscreen from LO 6.0 (26.96 KB, image/png)
2019-02-18 21:50 UTC, raal
Details
console logs (2.50 KB, text/plain)
2019-03-09 11:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2019-02-18 21:49:03 UTC
Description:
regression from 6.0

Steps to Reproduce:
1. open attached file in Calc
2.
3.

Actual Results:
xml is not imported

Expected Results:
open spreadsheet


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2019-02-18 21:49:35 UTC
Created attachment 149387 [details]
xml file
Comment 2 raal 2019-02-18 21:50:46 UTC
Created attachment 149388 [details]
printscreen from LO 6.0
Comment 3 raal 2019-02-18 21:52:36 UTC
This seems to have begun at the below commit.
Adding Cc: to Kohei Yoshida ; Could you possibly take a look at this one?
Thanks

author	Kohei Yoshida <kohei.yoshida@gmail.com>	2017-12-07 21:27:20 -0500
committer	Kohei Yoshida <libreoffice@kohei.us>	2017-12-18 02:31:24 +0100
commit	ca1a583e96f832797bf638d0b0a37840d35af5f9 (patch)
tree	d9088f6286625fcc6ec0f85249845778014d1100
parent	152c79ee2be2374334202dc738a8f011e47845c7 (diff)
Remove code duplicates.
Change-Id: I424e5999ef2ec6e71f6b6361ed91079b8d949555
Reviewed-on: https://gerrit.libreoffice.org/46656
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Kohei Yoshida <libreoffice@kohei.us>

error at command line
1:1: ��<?xml version='1.0'?>
     ^
malformed_xml_error: unsupported encoding. only 8 bit encodings are supported
Comment 4 Xavier Van Wijmeersch 2019-02-19 15:39:41 UTC
confirm with

Version: 6.1.4.2
Build ID: 9d0f32d1f0b509096fd65e0d4bec26ddd1938fd3
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded

Version: 6.3.0.0.alpha0+
Build ID: 5b2e38e0cfc7006d6982f741cf158a8a98dc8630
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Julien Nabet 2019-03-09 11:19:14 UTC
Created attachment 149840 [details]
console logs

On pc Debian x86-64 with master sources updated, I could reproduce this.
I noticed strange logs like:
MWAWHeader::constructHeader: find a potential MacPaint file

Also, is it on purpose that the file has xls extension whereas it's an xml file?
Comment 6 Kohei Yoshida 2019-03-14 23:53:39 UTC
This file is encoded in big-endian UTF-16, not the usual UTF-8 encoded ones.  I'll see if I can handle this on the orcus side.
Comment 7 raal 2019-04-07 19:48:51 UTC
*** Bug 124580 has been marked as a duplicate of this bug. ***
Comment 8 Kohei Yoshida 2019-08-15 13:02:16 UTC
Orcus has been upgraded on master, and with that, this issue is no longer reproducible.
Comment 9 Xisco Faulí 2019-08-19 10:51:19 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: cbe9601e5972ec1c466311e0b148a9fbe8cda4d1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Kohei, thanks for fixing this issue!
Comment 10 Xisco Faulí 2019-08-19 10:52:44 UTC
@Kohei, do you plan to backport it to 6.3 branch ?
Comment 11 Kohei Yoshida 2019-08-19 11:47:06 UTC
@Xisco, Nope, no backporting plan, as the change is rather big, and involves more than just the bug fix.