Download it now!
Bug 123947 - Export to PDF from Writer broke picture size (only width size). Could be linked to reducing dpi size
Summary: Export to PDF from Writer broke picture size (only width size). Could be link...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2019-03-08 16:17 UTC by roumanet
Modified: 2019-10-06 20:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison between ODT and PDF document (319.59 KB, image/png)
2019-03-08 16:18 UTC, roumanet
Details
original ODT document (1.24 MB, application/vnd.oasis.opendocument.text)
2019-03-08 16:19 UTC, roumanet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description roumanet 2019-03-08 16:17:02 UTC
Description:
On the attached document, trying to Export as PDF but result isn't correct on few pictures. These pictures are stretched without reason.

Steps to Reproduce:
Not able to reproduce on a new document.
However, I've made some try on incorrect pictures :
1. tried to change width in properties (with a) changing size in cm, b) click original size button) ► export still bad
2. Look at others settings on picture properties (scale 100%; keep ratio...) ► export still bad
3. Uncheck "minimize pictures resolution 300dpi" in export PDF dialog box ► picture is OK (but the document size grow up).

Actual Results:
Malformed picture in PDF (example Image35 in odt document)

Expected Results:
Normal picture in PDF


Reproducible: Sometimes


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 roumanet 2019-03-08 16:18:14 UTC
Created attachment 149830 [details]
comparison between ODT and PDF document
Comment 2 roumanet 2019-03-08 16:19:16 UTC
Created attachment 149831 [details]
original ODT document
Comment 3 Durgapriyanka 2019-03-08 17:30:40 UTC
Thank you for reporting the bug. I cannot reproduce this bug in

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 4 Oliver Brinzing 2019-03-09 09:23:32 UTC
i cannot confirm this with:

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

>(In reply to roumanet from comment #0)

can you provide a screenshot from File/Export As.../Export as PDF...
dialog, register "General" ?
Comment 5 Buovjaga 2019-04-08 19:50:15 UTC
roumanet: you said you have OpenGL enabled. Does it help, if you disable it? Tools - Options - LibreOffice - View - Use OpenGL for all rendering
Comment 6 QA Administrators 2019-10-06 03:19:21 UTC Comment hidden (obsolete)
Comment 7 roumanet 2019-10-06 20:01:47 UTC
I'm trying to test again but since 6.3.2, I'm not able to reproduce it (for PDF).
However, in 6.3.2 pictures in this ODT document aren't correctly shown when OpenGL is enabled.

But that not LibreOffice problem, I'll suppose.

Thanks a lot, you can close the bug.
Comment 8 Buovjaga 2019-10-06 20:11:24 UTC
(In reply to roumanet from comment #7)
> I'm trying to test again but since 6.3.2, I'm not able to reproduce it (for
> PDF).
> However, in 6.3.2 pictures in this ODT document aren't correctly shown when
> OpenGL is enabled.
> 
> But that not LibreOffice problem, I'll suppose.

It could be a LibreOffice problem. Otherwise, it could be a bad graphics driver and LibreOffice should automatically disable OpenGL rendering.