Download it now!
Bug 123960 - Conflicting shortcuts in Sheet menu of Calc
Summary: Conflicting shortcuts in Sheet menu of Calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2019-03-09 11:32 UTC by Mandar Mitra
Modified: 2019-07-14 16:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mandar Mitra 2019-03-09 11:32:04 UTC
Description:
Looks like Sheet -> Insert Rows and Sheet -> Rename Sheets are both bound to Alt+r, so pressing Alt+s Alt+r sequence has no effect. Earlier, I would use Alt+s Alt+r Alt+a to insert row above.

Steps to Reproduce:
1. Open a Calc file
2. Press Alt+s, the Sheets menu comes up
3. Press Alt+r, nothing happens (earlier, the Insert Rows submenu would come up)

Actual Results:
Nothing happens

Expected Results:
The Insert Rows submenu would come up in earlier versions.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2019-03-11 18:37:01 UTC
Shortcut Alt+R doesn't link to any action in Calc. I looked in 6.1, 6.2 and current master.
Alt+S shows menu because it is accesibility action for menu Sheet.

I think you have had your own keyboard shortcuts for Calc earlier.
Now you can add any shortcuts as you want from dialog Customize (Tools->Customize, tab Keyboard) 


This looks as NOTABUG
Comment 2 Mandar Mitra 2019-03-16 09:15:18 UTC
> Alt+S shows menu because it is accesibility action for menu Sheet.

"Shortcut" may have been the wrong term to use in my bug report; it looks like I meant "accesibility action".

I just checked with

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-IN (en_US.UTF-8); Calc: group threaded

and the three key sequence Alt+S Alt+R Alt+A indeed does insert a row above the current row in a Calc sheet.

I also confirmed that I have not assigned any shortcuts to any of these three keys myself. In any case, AFAIK, LibreOffice does not support shortcuts that consist of key sequences (as opposed to single keys, possibly with multiple modifiers).