Download it now!
Bug 123985 - basic command "print" causes crashes
Summary: basic command "print" causes crashes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-03-10 21:57 UTC by F. Tremmel
Modified: 2019-06-27 07:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
writer document with macro for testing "print" error. (14.01 KB, application/vnd.oasis.opendocument.text)
2019-03-10 21:57 UTC, F. Tremmel
Details
gdbtrace.log (36.09 KB, text/x-log)
2019-04-23 19:28 UTC, F. Tremmel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description F. Tremmel 2019-03-10 21:57:59 UTC
Created attachment 149867 [details]
writer document with macro for testing "print" error.

Since 6.0 Using the "print" command in Basic macros causes crashes.
Mostly the x-server is affected.

Theres a writer document with marco to test it.
The marco will start with a button on document.

Version: 6.2.1.2
Build-ID: 6.2.1 Chakra GNU/Linux-1
CPU-Threads: 8; BS: Linux 4.19; UI-Render: GL; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded

LibreOffice 6.2.1.2 cf8edfb50a0cb8924053cae33aad786aa12c469b
Comment 1 raal 2019-03-11 07:54:43 UTC
n crash with Version: 6.3.0.0.alpha0+
Build ID: 732d630c3d2a168c725c18e4dd8df7a0a4f85566
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

Seems to be fixed with dev version. Please could you test it with
dev version?  You can download it here:
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 2 F. Tremmel 2019-03-11 21:02:06 UTC
(In reply to raal from comment #1)
> n crash with Version: 6.3.0.0.alpha0+
> Build ID: 732d630c3d2a168c725c18e4dd8df7a0a4f85566
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> 
> Seems to be fixed with dev version. Please could you test it with
> dev version?  You can download it here:
> http://dev-builds.libreoffice.org/daily/master/
> Thank you

I will see what can be done.
Since it is my work computer and Libreoffice is a daily tool, I would prefer if someone could confirm the error first.
Comment 3 Xisco Faulí 2019-03-12 20:43:01 UTC
I can't reproduce it in

Version: 6.2.3.0.0+
Build ID: 3450311c403af714d3fc0ba14b9f7673c717a6a2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

what happens if you execute LibreOffice with SAL_USE_VCLPLUGIN=gtk3 soffice? Does it crash? I'm wondering if it's a kde5 problem...
Comment 4 Michael Weghorn 2019-03-13 07:02:58 UTC
I can't reproduce with

Version: 6.3.0.0.alpha0+
Build ID: 73e32aff2a3b8325daf36060140878fe34c46956
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded



(In reply to F. Tremmel from comment #2)
> I will see what can be done.
> Since it is my work computer and Libreoffice is a daily tool, I would prefer
> if someone could confirm the error first.

You can also install the dev version in parallel, by just putting it somewhere in a user directory, s. [1] for more details. This way, your existing LibreOffice installation will be unaffected.

[1] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 5 F. Tremmel 2019-04-18 14:27:15 UTC
I found the time to install libreoffice from git:

Version: 6.3.0.0.alpha0+
Build ID: 314d101b1336748b22df6582e7aacd455aa4171f
CPU threads: 8; OS: Linux 4.19; UI render: GL; VCL: kde5; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: CL


and I got the same error with the uploaded file.
After a view clicks on print dialog libreoffice and plasma desktop is freezing.

I have to change to the terminal and kill the soffice.bin process to keep an working with plasma.


With VCL_PLUGIN=gtk3 this error does not appear.
So it should be a problem with the kde5 integration.

plasma-framework 5.55.0
plasma-workspace 5.15.2
qt5-base 5.12.1
Comment 6 Michael Weghorn 2019-04-23 16:16:47 UTC
(In reply to F. Tremmel from comment #5)
> With VCL_PLUGIN=gtk3 this error does not appear.
> So it should be a problem with the kde5 integration.

Yes, sounds like that.

Can you please try to get a backtrace as described at [1] and attach it here?

[1] https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace
Comment 7 F. Tremmel 2019-04-23 19:28:28 UTC
Created attachment 150960 [details]
gdbtrace.log

I hope, it worked:
- started with --backtrace
- above example file loaded
- Error provoked -> desktop and soffice frozzen
- killed via terminal soffice

Is not that what was expected give me a second chance
Comment 8 Michael Weghorn 2019-04-23 20:01:05 UTC
Yes, thanks. In general, a backtrace generated with a debug build might show even more information, but I think that's enough for now.

The backtrace shows there's something going on in the X11 event handling and Qt's interaction with it:

> xcb_wait_for_reply () at /usr/lib/libxcb.so.1
> QXcbConnection::sync() () at /usr/lib/libQt5XcbQpa.so.5
> ...

Actually, the backtrace (and the overall behaviour) looks somewhat similar to bug 121293.
Comment 9 Michael Weghorn 2019-06-05 15:03:12 UTC
Bug 121293 has just been fixed and since this one here looks similar: Can you possibly retest once again with a current daily build of LibreOffice master (i.e. from tomorrow or newer) whether your issue is fixed as well?
Comment 10 Michael Weghorn 2019-06-13 18:12:03 UTC
There's an even better fix for bug 121293 that addresses the root cause instead of a workaround, s. https://gerrit.libreoffice.org/#/c/73567/ for details.

The fix has been backported to the 6.2 branch as well, which means it will be contained in the upcoming 6.2.5 release.

Most probably this bug will be gone with that fix in place; I'm therefore closing this bug as fixed. Please reopen if you can still reproduce with LibreOffice 6.2.5 or newer.
Comment 11 BogdanB 2019-06-26 18:51:24 UTC
No crash on
Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Xisco Faulí 2019-06-27 07:46:09 UTC
(In reply to BogdanB from comment #11)
> No crash on
> Version: 6.3.0.0.beta1
> Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
> Calc: threaded

This is a KDE5 issue, you tested with GTK3