Bug 123990 - FILEOPEN XLSX Conditional formatting of "Specific text" type should be case insensitive
Summary: FILEOPEN XLSX Conditional formatting of "Specific text" type should be case i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:7.5.0 target:7.4.3 inReleaseNo...
Keywords: filter:xlsx
: 152303 (view as bug list)
Depends on:
Blocks: XLSX-Conditional-Formatting
  Show dependency treegraph
 
Reported: 2019-03-11 05:26 UTC by Aron Budea
Modified: 2022-12-05 16:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample XLSX (8.98 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-03-11 05:26 UTC, Aron Budea
Details
Comparison screenshot (38.09 KB, image/png)
2019-03-11 05:27 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-03-11 05:26:18 UTC
Created attachment 149873 [details]
Sample XLSX

The attached XLSX contains sample conditional formatting created in Excel of type "Specific text" + all four types.
In Excel these rules are case insensitive, but in Calc they are interpreted case sensitively.

Observed using LO 6.3.0.0+ (4f810905fa74128871f2fe924a3d28a79f4e426), 4.0.0.3 / Windows 7.
Comment 1 Aron Budea 2019-03-11 05:27:01 UTC
Created attachment 149874 [details]
Comparison screenshot
Comment 2 Justin L 2020-07-15 06:20:17 UTC
This could probably be an easyhack (although in practice this means it will ~never get fixed).
-OUString comparisons: https://api.libreoffice.org/docs/cpp/ref/a00774.html
-comparision code in sc/source/core/data/conditio.cxx

[Easy, unless of course this should be different for LO formats than MSO. Do you think there would be an uproar if ODS files started doing case-insensitive conditional formatting?  (The answer of course is yes, someone would complain.)]
Comment 3 Justin L 2022-09-23 13:54:39 UTC
(In reply to Justin L from comment #2)
> (The answer of course is yes, someone would complain.)]
Actually, the answer should be no. Currently "equals" and "not equals" are already case insensitive. So it would be consistent for the other functions to work the same way.
http://gerrit.libreoffice.org/c/core/+/140484
Comment 4 Commit Notification 2022-09-23 15:38:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3bfed17b047422a8c4e98ab80001f3158afb227e

tdf#123990 sc condformat: case insensitive begins/ends/contains

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-09-27 19:55:41 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/27c22bac5439908ecdd1aa05580d75998a5eb058

tdf#123990 sc condition: use GetTransliteration, not GetCollator

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-10-01 10:19:53 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/080b2e56300865782ae65978ed9e510d667672a6

tdf#123990 sc condformat: case insensitive begins/ends/contains

It will be available in 7.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-10-01 10:25:03 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dd8775b051b40309d7d7e5730a3c5304d931f594

related tdf#123990 sc condition: GetCollator -> GetTransliteration

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-10-01 16:05:55 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cf805848ed5be4ba46eef9a8d3999d9b06848c60

related tdf#123990 sc condition: cleanup ScConditionMode::Between

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Eike Rathke 2022-11-30 00:24:01 UTC
*** Bug 152303 has been marked as a duplicate of this bug. ***
Comment 10 Stéphane Guillou (stragu) 2022-12-05 16:20:37 UTC
Verified as fixed in:

Version: 7.5.0.0.alpha1+ (X86_64) / LibreOffice Community
Build ID: 6d6a2343b1d45695f3ea02818d317a022a7b259f
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Thanks Justin!