Download it now!
Bug 124048 - alt key should open and highlight menubar
Summary: alt key should open and highlight menubar
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-Windows Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2019-03-13 10:29 UTC by AaronPeterson
Modified: 2019-06-25 15:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AaronPeterson 2019-03-13 10:29:02 UTC
This is standard windows behavior.  Firefox does it.. Chrome is broken...   arduino does it  Oracle virtualbox does it...


there was another bug 110452 which may have started this inappropriate behavior?

This is important for accessibility.  It makes the shortcut keys and interface discoverable by keyboard.

LibreOffice is still better than MS Office, thanks for the hard work! Hope this feedback helps.
Comment 1 V Stuart Foote 2019-03-13 14:29:58 UTC
(In reply to AaronPeterson from comment #0)
> This is standard windows behavior.  Firefox does it.. Chrome is broken...  
> arduino does it  Oracle virtualbox does it...
> ...

> 
> This is important for accessibility.  It makes the shortcut keys and
> interface discoverable by keyboard.
> ...


No this is not valid. As implemented on Windows builds of LibreOffice, the <Alt> key modifier will toggle Main menu bar active and positioning focus onto File menu. 

Changes were by design for cross platform behavior providing consistent accelerator behavior--by splitting the <Alt>, and then reading <nemonic>--was implemented when the accelerators were refactored for GTK3 compliance (bug 92630 at LO 5.1 release).

As currently implemented on Windows, the <Alt> modifier functions like the <F10> shortcut to position focus to the main menu--Movement <Left, Right, Down, Up> cursors are then necessary to navigate the menus. Alternatively, typing the mnemonics assigned to the "top" menu entries after an <Alt> modifier, function as accelerators to that menu.

Ongoing efforts adjusting UI to make consistent in all modules/dialogs including the Start Center. Consistency supports a11y--there is no "standard" MS Windows behavior.

All correct, and IMHO => NAB
Comment 2 Heiko Tietze 2019-03-14 09:36:52 UTC
The hotkeys behavior depends on the system. On Linux with Qt/Breeze the accelerator keys are underlined when alt is pressed, Unity shows the accelerator like Qt but when realeased it shows the quick search bar, W10 default programs show the accelerator keys as tips while LibreOffice (6.2) highlights the menu (alt along makes File light blue, alt+I insert etc.) as known from W7 and before. And macOS behaves completely different.

Cannot see any issue here and agree with Stuart on the NAB. Okay Aaron?
Comment 3 AaronPeterson 2019-05-25 06:12:56 UTC
So..   How do we use it?

It's the most common way the ALT key is used...

Most applications that I've used since DOS uses ALT to show the menu..

At least say WONT fix or it's a feature request...

Being consistent is important, and this is a HUGE inconsistency.
Comment 4 Xisco Faulí 2019-05-27 14:57:12 UTC
ALT highlights the menu for me in

Versión: 6.2.3.2
Id. de compilación: aecc05fe267cc68dde00352a451aa867b3b546ac
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 5 V Stuart Foote 2019-05-27 15:05:01 UTC
IIUC, the op want legacy behavior to not just highlight the File menu--but to also pop it open (rather than requiring a <Down> cursor to do so).

IMHO, functionally there is no difference.
Comment 6 Cor Nouws 2019-06-12 08:32:20 UTC
@aaronPeterson 
I had a hard time too, to get used to the new behavior. Since however it's the way how things work nowadays, I grumbled to myself now and then, and learned to live with it.
Can't make it look much nicier - sorry :)
Comment 7 Heiko Tietze 2019-06-13 07:37:19 UTC
Let's resolve it as NAB. Thanks for reporting anyway, Aaron.