Bug 124202 - No possible to connect to Internet sites from Calc (hyperlinks)
Summary: No possible to connect to Internet sites from Calc (hyperlinks)
Status: RESOLVED DUPLICATE of bug 124318
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:xls, regression
Depends on:
Blocks: XLS Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2019-03-19 09:40 UTC by JakGill
Modified: 2019-03-25 19:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File to explain the problem (17.00 KB, application/vnd.ms-excel)
2019-03-19 13:46 UTC, JakGill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JakGill 2019-03-19 09:40:40 UTC
Description:
When I click both on CTRL and on the cell which contains the hyperlink, I have an error message. I need to cut the hyperlink and to paste in the same cell, and then it's running.


Steps to Reproduce:
1.Save the file using Excel 97-2003 release
2.
3.

Actual Results:
You cannot have a correct action clicking on CTRL and hyperlink

Expected Results:
An immediate openning should be get


Reproducible: Always


User Profile Reset: No



Additional Info:
Save the file using Excel 2007-2019 or with.ODT extension, after changing all hyperlinks, using following method:
 - cut the hyperlink of the cell
 - paste in the same cell
Comment 1 m.a.riosv 2019-03-19 13:38:33 UTC
Please attach a sample file for test.
Comment 2 JakGill 2019-03-19 13:46:29 UTC
Created attachment 150101 [details]
File to explain the problem
Comment 3 m.a.riosv 2019-03-19 23:27:07 UTC
The link has a different text than the link, you can see the difference with Menu/Insert/Hyperlink [Ctrl+K].

As the text it's fine cut+paste works fine because the right link it's introduced.

Seems something in the file, because after correct and save & load the link is incorrect, but it's fine in a file from scratch.
Comment 4 raal 2019-03-24 21:57:07 UTC
I can confirm with Version: 6.3.0.0.alpha0+
Build ID: a11a2d84b09f85d2020c47f3ce42cd9efbff818a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

steps
 - new file
 - insert hyperlink with URL and text: https://espaceclient.lapostemobile.fr/mobile/identification/authentification
 - save as .xls
 - reload

Hyperlink is now: https://espaceclient.lapostemobile.fr/mobile/identification/authentification%00
Comment 5 raal 2019-03-24 21:59:52 UTC
Works in Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Regression
Comment 6 Xisco Faulí 2019-03-25 19:51:19 UTC
Duplicate of bug 124318

*** This bug has been marked as a duplicate of bug 124318 ***