Bug 124271 - Provide releases built with XCode 10
Summary: Provide releases built with XCode 10
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
: 125145 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-22 13:57 UTC by Alex Thurgood
Modified: 2019-05-28 06:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2019-03-22 13:57:49 UTC
Description:
For macOS, currently, LibreOffice is not built with XCode 10, release build bots have had to be switched back to XCode 9, as building with XCode 10 causes repeated overload in calls to CoreGraphics functions leading to an inevitable crash.

The aim of this bug is just to bear in mind that this problem is unlikely to go away by itself and at some stage will need fixing. 

Steps to Reproduce:
1) Build LO source code with XCode 10
2) Start the resulting app from the build
3) Scroll anywhere in a menu with an up/down scrollbar or resize window then scroll, watch LO make repeat calls to CG functions causing it to eventually consume all resources and/or crash.

Actual Results:
See steps to reproduce

Expected Results:
Scrolling, window resizing, should behave normally and not cause excessive system resource consumption


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Alex Thurgood 2019-03-22 13:59:43 UTC
Note that this follows on from bug 121778
Comment 2 Aron Budea 2019-03-22 14:08:57 UTC
Confirmed by Tor in bug 121778 comment 76:
"At least the resize-Calc-document, scroll-back-and-forth-a-bit scenario still causes the process to get stuck at 100% cpu usage in a master build with Xcode 10.1."
Comment 3 Alex Thurgood 2019-05-13 07:14:17 UTC
*** Bug 125145 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2019-05-21 23:34:49 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/959e8ae7ea33ce94dd80ee8ea172b6db64593873%5E%21

tdf#124271 use the bitmap context, handle scaling

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Alex Thurgood 2019-05-28 06:50:20 UTC
Testing with 

Version: 6.3.0.0.alpha1+
Build ID: 92b0b8d78d69bd917842b09af7888b402144baeb
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

seems indeed to show that the problem no longer occurs, marking as resolved fixed, thanks !