Bug 125145 - LibreOffice freezes after resizing window in Mac
Summary: LibreOffice freezes after resizing window in Mac
Status: RESOLVED DUPLICATE of bug 124271
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-05-06 21:28 UTC by Thorsten Wagner
Modified: 2019-05-13 07:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Wagner 2019-05-06 21:28:43 UTC
Description:
LibreOffice becomes very low and freezes after resizing main window of any LibreOffice application.

Steps to Reproduce:
1. Open any application (Writer, Calc, Impress, Draw)
2. Drag application window at right lower corner to resize
3. Try to use opened application

Actual Results:
LibreOffice becomes very slow, UI presentation becomes garbled, LibreOffice freezes.

Expected Results:
LibreOffice continues working without performance issues / freezing.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Issue exists on macOS, Linux is not affected. It appears on macOS 10.14.4 at least. Issue is independend of OpenGL.
Comment 1 Xisco Faulí 2019-05-07 20:01:49 UTC
Thanks for reporting this issue.
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: e575a5e8f89beb3ce1df5a1d83edc0f9d1d8ac43
CPU threads: 8; OS: Mac OS X 10.14.2; UI render: default; VCL: osx; 
Locale: en-US (en_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 2 Thorsten Wagner 2019-05-07 20:25:31 UTC
Version: 6.3.0.0.alpha0+
Build ID: 8c71d28069acffa2d4590a4acf95a98d1415b563
CPU threads: 8; OS: Mac OS X 10.14.4; UI render: GL; VCL: osx; 
Locale: de-DE (en_DE.UTF-8); UI-Language: en-US
Calc: threaded

Xcode is release 10.2.1.

Issue should be visible very good after resizing macro editor window with AutoText pane selected. I don't know wheater reason is the same as reason for the behaviour described, but freezing appears directly at this place.
Comment 3 Alex Thurgood 2019-05-09 10:22:34 UTC
Isn't this a DUP, related to not being able to build with XCode10 without causing scrolling freeze in use, hence release builds made with XCode9 ?
Comment 4 Thorsten Wagner 2019-05-11 09:52:42 UTC
Maybe, it is a dup. Is there any known reason of the issues with Xcode 10? For example building of LO 5.4.6 works with Xcode 10 and macOS 10.14 SDK without problems.
Comment 5 Thorsten Wagner 2019-05-11 14:15:42 UTC
Issues disappeared with Xcode 10.2.1 but macOS SDK 10.13. So issues seem to be related to SDK, not to Xcode or Compiler toolchain itself.

Additional observation: Building with SDK 10.13 completes without unit test failures, Building with SDK 10.14 breaks with the following unit test failure:

sw/qa/extras/uiwriter/uiwriter2.cxx:1191: Assertion
Test name: testTdf124261::TestBody
equality assertion failed
- Expected: 1721
- Actual  : 2795
Comment 6 Thorsten Wagner 2019-05-11 17:27:48 UTC
Unit test failure is not related to macOS JDK. Failure occurs with JDK 10.13 too, but on Mac Pro. There seems to be a difference between Mac Pros and MacBook Pros, maybe CPU (Xeon vs. i7).
Comment 7 Alex Thurgood 2019-05-13 07:09:07 UTC
Reproduced with my own master build:

Version: 6.3.0.0.alpha0+
Build ID: 03a2f3ec4316a3953c2fa40e6e59c2ebbc824d09
CPU threads: 4; OS: Mac OS X 10.14.4; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded



built with XCode 10.2.1

with the following steps :

Start LO
Open a new Calc document
Resize the Calc window with the mouse
Now try scrolling up or down within the Calc sheet. LO slows down to the point of freezing the application as a whole.
Comment 8 Alex Thurgood 2019-05-13 07:14:17 UTC

*** This bug has been marked as a duplicate of bug 124271 ***
Comment 9 Alex Thurgood 2019-05-13 07:15:19 UTC
See also bug 121778