Bug 124275 - Switching from None to Continuous on a shape that touches a margin pushes out that margin upon export to GIF/PNG/etc.
Summary: Switching from None to Continuous on a shape that touches a margin pushes out...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2019-03-22 14:37 UTC by xordevoreaux
Modified: 2020-10-16 13:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO DRAW document (9.31 KB, application/vnd.oasis.opendocument.graphics)
2019-03-22 14:39 UTC, xordevoreaux
Details
line box property snapshot (36.57 KB, image/png)
2019-03-22 14:40 UTC, xordevoreaux
Details
export showing line using default line thickness on shape (5.36 KB, image/gif)
2019-03-22 14:41 UTC, xordevoreaux
Details
Same shape exported having manipulated the line property (4.99 KB, image/gif)
2019-03-22 14:41 UTC, xordevoreaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xordevoreaux 2019-03-22 14:37:49 UTC
Description:
Very obscure bug and a bit complicated so I'll try to be as clear as possible. 

I have a document in LO Draw with no margins. In that document I created a shape (a box) and made sure that the edges of the box extend to either side so that the edges touch the margin.  

I then exported the document as a GIF (happens with other formats like PNG).  
A white line appeared to the right and bottom of the export.

I went back to the document and selected None instead of having the default of Continuous for the shape's border (line property). The white line on the export went away.

Here is the complicated part:
If you flip the thickness of the line to anything other than the default, regardless what you select, the white line does not appear on export. This only happens on a new shape with the default line property set.  

Once you change the line's thickness from the default (can even back to something else and then back to the default again) the export works as intended.

I am attaching the document I used plus the output plus a screen shot showing the property I'm adjusting.  Again, leaving the shape's line thickness to the default when exporting seems to be the initial problem.


Steps to Reproduce:
1.Create a new LO Draw document
2.Set the document's margins to 0
3.Create a shape whose edge touches the right margin of the document.
4.Export the document to Gif/PNG/etc.

Actual Results:
A white line appears to the right and bottom of the document.

Expected Results:
No white line should appear.


Reproducible: Always


User Profile Reset: No



Additional Info:
As soon as one adjusts the line property to something other than the default thickness, the problem seems to correct itself, even if returning the property to the default thickness. If this extra step isn't taken, the line remains.
Comment 1 xordevoreaux 2019-03-22 14:39:38 UTC
Created attachment 150189 [details]
LO DRAW document
Comment 2 xordevoreaux 2019-03-22 14:40:34 UTC
Created attachment 150190 [details]
line box property snapshot
Comment 3 xordevoreaux 2019-03-22 14:41:10 UTC
Created attachment 150191 [details]
export showing line using default line thickness on shape
Comment 4 xordevoreaux 2019-03-22 14:41:47 UTC
Created attachment 150192 [details]
Same shape exported having manipulated the line property
Comment 5 mulla.tasanim 2019-03-22 17:40:20 UTC
Hello

Thank you for reporting the bug.

I can not reproduce the bug in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


I have exported document to both formats Gif/PNG 
Also I have extended edge of box outside of the right side of page still White Line is not appearing
Comment 6 xordevoreaux 2019-03-22 20:19:42 UTC
Well obviously it's happening because I attached the screenshots to prove it. 

1. Be sure you're first exporting the slide without manipulating the line thickness
2. Extend the shape to meet the edge of the slide, not extend past it.
3. Be sure you have zero margins set up on the document.

Worst case just use the document I attached and export it as-is if you want to see it happen.
Comment 7 Buovjaga 2019-04-20 16:54:28 UTC
This seems to be the same root cause as your bug 117160.
Testing with PNG export, I don't see the problem in 3.5.0, but already see it in 4.3.0 (top and left have a transparent edge). In 6.3.0 I get a transparent edge all around the image except where the blue borders are.

I could try a bibisect of bug 117160 on Linux.
Comment 8 Buovjaga 2019-04-20 17:08:06 UTC
Nope, like I mentioned in bug 117160, I cannot repro with the same older versions on Linux as I can on Windows! Even version 5.0 is fine on Linux, with both the steps in bug 117160 and the file in this report.

We would need even older bibisect repos for Windows.

Let's keep this open for now as we are not 100% certain it is a duplicate of your older report.
Comment 9 xordevoreaux 2020-10-16 13:41:31 UTC
Works for me using

Version: 7.1.0.0.alpha0+ (x64)
Build ID: df74aef7159d7155addf78cfc4d139485945d794
CPU threads: 8; OS: Windows 10.0 Build 20236; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded


I'm no longer seeing what I did in the original attachments.
All I see now as far as artifacts is the bug 117160 (line top and left)