Bug 124367 - FILEOPEN DOCX table cell content flow changes
Summary: FILEOPEN DOCX table cell content flow changes
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Bakos Attila (NISZ)
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisected, bisected
: 124638 127337 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-03-27 15:14 UTC by NISZ LibreOffice Team
Modified: 2019-11-13 08:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (81.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-03-27 15:15 UTC, NISZ LibreOffice Team
Details
Screenshot (60.08 KB, image/png)
2019-03-27 15:15 UTC, NISZ LibreOffice Team
Details
comparison MSO 2010 and LibreOffice 6.4 Master (26.66 KB, image/png)
2019-11-04 10:29 UTC, Xisco Faulí
Details
Minimized example file (11.89 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-11-04 13:08 UTC, NISZ LibreOffice Team
Details
Screenshot of the minimized file in Word 2013 and Writer 6.4master (65.22 KB, image/png)
2019-11-04 13:09 UTC, NISZ LibreOffice Team
Details
Problem solved in LO6.4-master (82.11 KB, image/png)
2019-11-11 08:00 UTC, Bakos Attila (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-03-27 15:14:06 UTC
Description:
Table cell content flow in DOCX documents created with Microsoft Word changes when the document is opened in LibreOffice Writer 6.3.0.0.alpha0+.

Steps to Reproduce:
    1. Open the attached DOCX file in LibreOffice Writer.
    2. Open a copy in Microsoft Word.
    3. Compare the original file opened in Writer and Word.
    4. View the attached screenshot.
    5. Notice, that table cell content flow changes.

Actual Results:
Table cell content flow changes when the document is opened in LibreOffice Writer 6.3.0.0.alpha0+.

Expected Results:
Table cell content flow should have the position as the original file when the document is opened in Microsoft Word.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.3.0.0.alpha0+
Build ID: ade1df0948563b532a5d293c31d46a4f042559ee
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Bibisect log:
# bad: [f7c1838d18d55ceb798a86680ce8a2e9b083f3ef] source sha:ade1df0948563b532a5d293c31d46a4f042559ee
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'origin/master' 'oldest'
# good: [bdc1d1813ab88aba96b72536898293ae576016e6] source sha:1bf68dbf53f4b5308e295058226abd6d6fb49c3d
git bisect good bdc1d1813ab88aba96b72536898293ae576016e6
# good: [ddd5d7fc335077df25fb027ab9211c3917933b68] source sha:358b8a451f502d53e01e6b1dc6afa24ee9c5e8bc
git bisect good ddd5d7fc335077df25fb027ab9211c3917933b68
# good: [dcf9e91fc6ab11a4a89e77fd30721b5c624cdc12] source sha:cddf072a62208d2514f97ba5c0d3577d7d88b8de
git bisect good dcf9e91fc6ab11a4a89e77fd30721b5c624cdc12
# bad: [51edcab8dbde45ed436f04ea2aa725e808488e1a] source sha:33a3d806ff065c302283e4d7db522762eda428f8
git bisect bad 51edcab8dbde45ed436f04ea2aa725e808488e1a
# good: [94a56eb839b878aaa6b36e3eb1ade469efa297d4] source sha:3ae8b9301fa817968f3115639bc8a5f2170d179e
git bisect good 94a56eb839b878aaa6b36e3eb1ade469efa297d4
# bad: [5d73cc7897b1ac1bdc4116aa41e58afb0f6700f4] source sha:b636d57e8f6d98887b1cd11449dd9580beb7b604
git bisect bad 5d73cc7897b1ac1bdc4116aa41e58afb0f6700f4
# good: [c13086631fde77ea836696ea4e689d0ebb7e8fe9] source sha:4c4ccdf724dedebce23cc9abd7b74bee43f184d7
git bisect good c13086631fde77ea836696ea4e689d0ebb7e8fe9
# good: [229902480870b1cd768822b436f953823d02135a] source sha:212a40aaf7ec3316d5209b688f5f79821f99fbdc
git bisect good 229902480870b1cd768822b436f953823d02135a
# bad: [ed5e0e48e301c36fba5b34fbcf6dd8e333bd35d3] source sha:fde00c42b169d80c9fe850d4876a0d0e5d6744a6
git bisect bad ed5e0e48e301c36fba5b34fbcf6dd8e333bd35d3
# bad: [2c247c35ef930355aceb50e006627a327f107831] source sha:e502463fa9a601963aa9f5a8783eb1318de36c13
git bisect bad 2c247c35ef930355aceb50e006627a327f107831
# good: [7e872e72efa5ff0a99f6cd37a87dc3ab3908f743] source sha:5c27a048658afcd2f78ef4d7e6c7128554ed3f4c
git bisect good 7e872e72efa5ff0a99f6cd37a87dc3ab3908f743
# good: [825290edf00d729d10100086cab0c62fbbb3a489] source sha:af836fe33dd42c6043ef70f897c90c8b3ba826a7
git bisect good 825290edf00d729d10100086cab0c62fbbb3a489
# first bad commit: [2c247c35ef930355aceb50e006627a327f107831] source sha:e502463fa9a601963aa9f5a8783eb1318de36c13
Comment 1 NISZ LibreOffice Team 2019-03-27 15:15:32 UTC
Created attachment 150321 [details]
Test file
Comment 2 NISZ LibreOffice Team 2019-03-27 15:15:53 UTC
Created attachment 150322 [details]
Screenshot
Comment 3 NISZ LibreOffice Team 2019-03-27 15:28:56 UTC
Adding Cc: to Miklos Vajna
Comment 4 Miklos Vajna 2019-03-27 15:32:45 UTC
Bisect is useful here, but if you read the commit message of e502463fa9a601963aa9f5a8783eb1318de36c13, it explains why this rounding is a promise we can't hold at the moment.

So there was a timeframe when this worked, but only by breaking vertical merges, so at the end of the day this didn't really work ever, so it's not clear if this is a regression or not, probably not.
Comment 5 Xisco Faulí 2019-03-27 16:33:36 UTC
Removing 'regression' keyword and setting it to NEW based on comment 4
Comment 6 Xisco Faulí 2019-11-04 10:29:07 UTC
Created attachment 155499 [details]
comparison MSO 2010 and LibreOffice 6.4 Master
Comment 7 Xisco Faulí 2019-11-04 10:30:22 UTC
Hello NISZ Team,
looking at your screenshot, I can't identify what this report is about. See how it looks for me in master

Version: 6.4.0.0.alpha1+
Build ID: fa7f07d23de31e5f1660a643d83ca8a2e565f69c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Please, make it clear what the problem is
Comment 8 NISZ LibreOffice Team 2019-11-04 13:08:28 UTC
Created attachment 155505 [details]
Minimized example file
Comment 9 NISZ LibreOffice Team 2019-11-04 13:09:45 UTC
Created attachment 155506 [details]
Screenshot of the minimized file in Word 2013 and Writer 6.4master
Comment 10 NISZ LibreOffice Team 2019-11-04 13:12:06 UTC
The simplified file highlights the series of x-es that have one last letter in the following line.

Also, a clickable link:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e502463fa9a601963aa9f5a8783eb1318de36c13
Comment 11 Xisco Faulí 2019-11-04 13:30:51 UTC
oh, I see the problem now.
Thanks for the clarification
Comment 12 Commit Notification 2019-11-09 17:21:55 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c401aa9f632758157021c2c45c5cc4d00ee12dab

tdf124367 DOCX import: fix rounding error in table cell widths

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Bakos Attila (NISZ) 2019-11-11 08:00:31 UTC
Created attachment 155697 [details]
Problem solved in LO6.4-master
Comment 14 Bakos Attila (NISZ) 2019-11-11 08:03:08 UTC
*** Bug 124638 has been marked as a duplicate of this bug. ***
Comment 15 Bakos Attila (NISZ) 2019-11-11 08:05:50 UTC
*** Bug 127337 has been marked as a duplicate of this bug. ***
Comment 16 Xisco Faulí 2019-11-11 09:32:40 UTC
Verified in

Version: 6.4.0.0.alpha1+
Build ID: fea5c10e222b10d83e0081dc1d1b2e678689d250
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Bakos Attila, thanks for fixing this issue!
Comment 17 Bakos Attila (NISZ) 2019-11-11 09:56:33 UTC
(In reply to Xisco Faulí from comment #16)
> Verified in
> 
> Version: 6.4.0.0.alpha1+
> Build ID: fea5c10e222b10d83e0081dc1d1b2e678689d250
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> @Bakos Attila, thanks for fixing this issue!

You are welcome! Thanks for verifying it!
Comment 18 Commit Notification 2019-11-13 08:34:13 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/23d8c2b148f88575a9c971602d3a1bc71dabf0b1

tdf#124367 DOCX import: fix rounding error in table cell widths

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.