Bug 124638 - FILEOPEN: Cell size incorrectly calculated
Summary: FILEOPEN: Cell size incorrectly calculated
Status: RESOLVED DUPLICATE of bug 124367
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-04-09 23:55 UTC by Xisco Faulí
Modified: 2019-11-11 12:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample file (14.04 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-09 23:55 UTC, Xisco Faulí
Details
BeforeAndAfterInLO6.4A1+ (105.25 KB, image/png)
2019-11-11 08:04 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-09 23:55:33 UTC
Created attachment 150637 [details]
sample file

Steps to reproduce:
1. Open attached document

-> Check first column of the table. 2 digits numbers don't fit. See attached screenshot

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 040a54d89e8ca33171e86647ced8dc58efd85fbe
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-04-10 00:00:37 UTC
This issue was reintroduced in commit https://cgit.freedesktop.org/libreoffice/core/commit/?id=e502463fa9a601963aa9f5a8783eb1318de36c13 when https://cgit.freedesktop.org/libreoffice/core/commit/?id=29cbbad64088354425c606f9eb6c267bdf7731dc was reverted.

However, the original regression comes from

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4d34d43b29be2b14a02b001b35fcde2459fb1993

author	sushil_shinde <sushil.shinde@synerzip.com>	2014-01-22 17:10:11 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-02-13 10:25:16 +0100
commit 4d34d43b29be2b14a02b001b35fcde2459fb1993 (patch)
tree 969629de48f4f64e5a3c63a11d918b981e767118
parent 9d5005a70cc42ee9f45104cc32aa099d0c3d6630 (diff)
fdo#69656 table with auto-width and at least one column with auto-width.

Bisected with bibisect-43max

@Miklos, I thought you could be interested in this issue...
Comment 2 Gabor Kelemen (allotropia) 2019-04-10 13:01:03 UTC
This is probably a dupe to our bug #124367
Comment 3 Attila Bakos (NISZ) 2019-11-11 08:03:08 UTC

*** This bug has been marked as a duplicate of bug 124367 ***
Comment 4 Attila Bakos (NISZ) 2019-11-11 08:04:12 UTC
Created attachment 155698 [details]
BeforeAndAfterInLO6.4A1+